CISCO寄存器值及調試

來源:本站原創 CISCO 超過1,025 views圍觀 0條評論

Cisco路由器的內部組件

1.       bootstrap

2.       post

3.       ROM

4.       小型IOS

5.       RAM

6.       ROM

7.       NVRAM

8.       Configuration register

路由器啟動順序

啟動順序包括下列步驟

1.  路由器執行POST。

2.  Bootstrap查找并加載Cisco IOS軟件。

3.  IOS軟件在NVRAM中查找有效的配置文件。

4.  如果NVRAM中有startup-config文件,路由器將加載并運行此文件。

管理配置寄存器

所有Cisco路由器都具有一個位于NVRAM中的16位軟件寄存器。默認情況下,配置寄存器設置為從閃存加載startup-config文件。

理解配置寄存器位

配置寄存器的16位從左到右是從15讀到0。Cisco路由器默認的配置設置時0x2102。

軟件配置意義


十六進制
解釋
0-3
0x0000-0x000f
啟動字段
6
0x0040
忽略NVRAM內容
7
0x0080
啟用OEM位
8
0x101
禁用中斷
10
0x0400
IP廣播全為零
5、11-12
0x0800-0x1000
控制臺線路速率
13
0x2000
如果網絡啟動實效則啟動默認ROM軟件
14
0x4000
IP廣播包含網絡號
15
0x8000
啟用診斷信息并忽略NVRAM內容

位于配置寄存器0位-3位的啟動字段控制路由器的啟動順序。

檢查當前配置寄存器值

使用show version命令可以查看配置寄存器的當前值。

Cisco Internetwork Operating System Software

IOS ™ 2500 Software (C2500-JS56I-L), Version 12.1(5)T12,  RELEASE SOFTWARE (fc1)

TAC Support: http://www.cisco.com/tac

Copyright (c) 1986-2002 by cisco Systems, Inc.

(略)

Configuration register is 0x2142

命令最后給出的信息就是配置寄存器的值。

修改配置寄存器的值

可以通過修改配置寄存器的值來修改路由器如何啟動和運行。

下面是修改配置寄存器的可能原因:

1.  強制系統進入ROM監控模式

2.  選擇啟動來源和默認的啟動文件名

3.  啟用或禁用Break(中斷)功能

4.  控制廣播地址

5.  設置控制臺中斷波特率

6.  從ROM加載操作軟件

7.  啟用從TFTP啟動服務器

使用config-register命令修改配置寄存器。

下面命令告訴路由器忽略NVRAM內容:

Router(config)#config-register 0x2142

Router(config)#^Z

Router#sh ver

(略)

Configuration register is 0x2142

恢復口令

如果忘記了口令,可以通過修改寄存器的值來進行恢復。

默認的配置寄存器值是0x2102,在默認情況下,路由器會查找并加載存儲在NVRAM中的路由器配置。現在我們要更改值,讓路由器忽略NVRAM的內容。

這里是口令恢復的主要步驟:

1.  啟動路由器并通過執行一個中斷來中斷啟動順序

2.  修改配置寄存器開啟第6位(值為0x2142)

3.  重載路由器

4.  進入特權模式。

5.  將startup-config文件復制為running-config文件

6.  修改口令

7.  將配置寄存器重設為默認值

8.  保存路由器的配置

9.  重載路由器。

下面是詳細步驟:

中斷路由器啟動順序

做法是,當路由器第一次啟動時同時按下CTRL+BREAK組和鍵來執行一個中斷。

修改配置寄存器

2600系列命令

Rommon 1> confreg 0x2142

2500系列命令

>o/r 0x2142

從載路由器進入特權模式

再此情況下,需要像下面這樣從蛇路由器:

2600系列上,輸入reset

2500系列上,輸入I(初始化)

查看并修改配置

將startup-config文件復制到running-config文件

Copy startup-config running-config

縮寫 copy start run

但是不能查看secret設置的口令。要修改口令,這樣做

Config t

Enable secret 12345

重設配置寄存器并重載路由器

使用config-register命令將配置寄存器設置回默認值:

Config t

Config-register 0x2102

最后使用Copy run start 命令保存配置并重載路由器。

備份和恢復Cisco IOS

在省級或恢復Cisco IOS之前,應當將已有文件復制到TFTP主機作為備份,以防止新的影響文件不能正常運行。

在將IOS映像文件備份到網絡服務器之前,完成下列操作:

1.  確定可以訪問網絡服務器。

2.  確保網絡服務器對于影響文件具有足夠的空間。

3.  驗證所需的文件名以及路徑。

驗證閃存

當場是在路由器上用心的IOS文件升級Cisco IOS之前,應當驗證閃存具有充足的空間來保存新的映像文件。可以使用sh flash命令驗證閃存的容量和姚存儲到閃存中文件的大小:

Router#sh flash

System flash directory:

File  Length   Name/status

  1   16082856  c2500-js56i-l.121-5.T12.bin 

[16082920 bytes used, 694296 available, 16777216 total]

16384K bytes of processor board System flash (Read ONLY)

這里文件名是c2500-js56i-l.121-5.T12.bin。這個文件名稱具有平臺特性,名稱來源如下:

1.  C2500是指平臺類型

2.  J指示此文件時一個企業級映像文件

3.  S指示文件包含擴展性能

4.  L指示在需要時可以從閃存中刪除此文件,并且此文件時不可壓縮文件

5.  T12是版本號

6.  .bin指示Cisco IOS是二進制可執行文件

備份Cisco IOS

若要將Cisco IOS備份到TFTP服務器,使用copy flash tftp命令

恢復或升級Cisco路由器IOS

可以使用copy tftp flash命令將文件從TFTP服務器下載到閃存中。此命令需要TFTP服務器的IP地址以及要下載到閃存中的文件名。

在開始操作之前,要確保欲放置到閃存中的文件在服務器默認的TFTP目錄下。

備份和恢復Cisco配置

對于路由器配置進行的任何修改存儲在running-config文件中。在修改了running-config后沒有執行copy run start命令,那么路由器重載或掉電后修改的內容會丟失。

備份Cisco路由器配置

要把路由器的配置文件從路由器復制到TFTP服務器,可以使用copy running-config tftp或copy startup-config tftp。其中一個備份當前正在DRAM中運行的路由器配置,一個備份存儲在NVRAM中的路由器配置。

驗證當前配置

可以使用sh running-config命令

Router>en

Router#sh run

Building configuration…

Current configuration : 547 bytes

!

version 12.1

當前信息表明路由器運行的是IOS 12.1版本

驗證存儲的配置

下面,應當檢查NVRAM中存儲的配置。要察看此配置,使用sh start命令:

Router#sh start

Using 547 out of 32762 bytes

!

version 12.1

將當前配置復制到NVRAM

將running-config復制到NVRAM作為備份,可以確信路由器重載時總是重載Running-config文件。

Router#copy run start

Destination filename [startup-config]? [Enter]

Building configuration…

[OK]

Router#

將配置復制到TFTP服務器

使用copy run tftp命令

恢復Cisco路由器配置

使用copy tftp run命令

刪除配置

使用erase startup-config命令

Router#erase startup-config

Erasing the nvram filesystem will remove all files! Continue? [confirm][Enter]

[OK]

Erase of nvram: complete

Router#

使用Cisco發現協議

Cisco發現協議(CDP)是Cisco私有,幫助用來管理員收集本地相連和遠程設備的信息.

獲取CDP定時器和保持時間信息

之前提到過CDP的一些介紹,show cdp命令提供2個信息給你:

1.CDP timer:CDP包傳給每個活躍接口的時間間隔,默認是60秒

2.CDP holdtime:某設備從相鄰設備收到的包的保持時間,默認是180秒

如下:

Router#sh cdp

Global CDP information:

Sending CDP packets every 60 seconds

Sending a holdtime value of 180 seconds

Router#

可以修改默認的時間,分別在全局配置模式下使用cdp timer和cdp holdtime命令,如下:

Router#conf t

Router(config)#cdp timer 90

Router(config)#cdp holdtime 240

在所有接口上關閉CDP,在全局配置模式下使用no cdp run命令;關閉某個接口的CDP使用no cdp enable命令.再次打開分別使用cdp run和ccdp enable命令.如下:

Router(config)#no cdp run

Router(config)#int fa0/1

Router(config-if)#no cdp enable

收集鄰居信息

使用show cdp neighbour可以顯示直接相連的設備的信息,如下:

Router#sh cdp nei

Capability Codes: R – Router, T – Trans Bridge,

B – Source Route Bridge, S – Switch, H – Host,

I – IGMP, r – Repeater

Device ID Local Intrfce Holdtime Capability Platform Port ID

1900Switch Eth 0 238 T S 1900 2

2500B Ser 0 138 R 2500 Ser 0

Router#

一些選項的解釋如下:

1.Device ID:直接相連的設備的主機名

2.Local Interface:接收CDP包的接口

3.Holdtime:某設備從相鄰設備收到的包的保持時間,如果過了這個時間仍然沒收到新的CDP包,就將被丟棄

4.Capability:見輸出最頂部信息

5.Platform:Cisco設備的類型

6.Port ID:相連設備的接受CDP包信息的接口

要查看更為詳細的CDP信息可以使用show cdp neighbor detail或show cdp entry *命令

收集借口流量信息

使用show cdp traffic命令顯示接口CDP包流量信息,如下:

Router#sh cdp traffic

CDP counters:

Packets output: 13, Input: 8

Hdr syntax: 0, Chksum error: 0, Encaps failed: 0

No memory: 0, Invalid packet: 0, Fragmented: 0

Router#

收集端口和接口信息

使用show cdp interface命令顯示接口的CDP狀態信息

使用Telnet

在特權模式下使用telnet [IP地址]的命令進行telnet,如下:

Router#telnet 172.16.10.2

Trying 172.16.10.2 … Open

Password required, but none set

[Connection to 172.16.10.2 closed by foreign host]

Router#

由上面提示可以看出,VTY沒有密碼配置的話是不允許你telnet的(除非你使用了no login命令,但是安全性幾乎為0).所以在telnet前,記得先給目標設備的VTY線路配置密碼

同時Telnet到多個設備

當你telnet到遠程設備的時候,可以在任何情況下使用exit命令來終止連接.但是假如你想保持這個連接,同時又對另外1個設備進行telnet的時候,使用Ctrl+Shift+6,再按下X鍵,就可以回到本地console,再對另外1設備進行telnet.如下:

2500#telnet 172.16.10.2

Trying 172.16.10.2 … Open

User Access Verification

Password:

2600>[Ctrl+Shift+6,X]

2500#telnet 192.168.0.32

(略)

檢查Telnet連接

查看從本地到遠程的連接會話,使用show sessions命令,如下:

2500#sh sessions

Conn Host Address Byte Idle Conn Name

1 172.16.10.2 172.16.10.2 0 0 172.16.10.2

*2 192.168.0.32 192.168.0.32 0 0 192.168.0.32

2500#

注意*所在的會話代表你的最后1個會話,可以直接敲2下Enter鍵回到*號會話,也可以輸入前面的數字,再敲2下Enter鍵回到相應會話

檢查Telnet用戶

使用show users命令列舉本地所有活動console和VTY端口,如下:

2500#sh users

Line User Host(s) Idle Location

* 0 con 0 172.16.10.2 00:07:52

192.168.0.32 00:07:18

注意上面輸出的con代表本地console,這個例子可以看到從本地console連接了遠程的2個設備.接下來在我們遠程設備上使用這個命令,如下:

2600>sh users

Line User Host(s) Idle Location

0 con 0 idle 9

*2 vty 0

這個輸出內容可以看出console是活動的,而且VTY端口2被使用

關閉Telnet會話

之前說過,要終止telnet會話,在遠程(被telnet)設備上使用exit命令.但是要從本地設備終止會話的話,就需要在本地使用disconnect命令,如下:

2500#disconnect ?

<1-2> The number of an active network connection

WORD The name of an active network connection

<cr>

2500#disconnect 1

Closing connection to 172.16.10.2 [confirm]

2500#

驗證如下:

2600#sh users

Line User Host(s) Idle Location

*0 con 0 idle 0

1 aux 0 idle 0

2 vty 0 idle 172.16.10.1

清除連接,使用clear line命令,并驗證,如下:

2600#clear line 2

[confirm]

[OK]

2600#sh users

Line User Host(s) Idle Location

*0 con 0 idle 0

1 aux 0 idle 1

2600#

解析主機名

2種解析主機名到IP地址的辦法:

1.在每個router上建立主機表(host table)

2.建立DNS服務器(Domain Name System server),這個類似動態主機表

建立主機表

主機表只提供包含其中的解析,建立主機表的命令是ip host [主機名] [TCP端口號] [IP地址],默認TCP端口號為23.1個主機可以對應最多8個IP地址.如下:

2500(config)#ip host 2501B 172.16.10.2

2500(config)#ip host 1900S 192.168.0.32

2500(config)#^Z

使用show hosts命令驗證新建的主機表,如下:

2500#sh hosts

Default domain is not set

Name/address lookup uses domain service

Name servers are 255.255.255.255

Host Flags Age Type Address(es)

2501B (perm, OK) 0 IP 172.16.10.2

1900S (perm, OK) 0 IP 192.168.0.32

2500#

注意Flags選項的perm,代表是手動輸入的,如果這項是temp的話,表明是由DNS解析的

使用DNS解析名稱

假如你在CLI下輸入了1個Cisco設備不能識別的命令,它會默認通過DNS來進行解析(它認為是主機名).這個不好的地方是要花費額外的時間等待DNS解析完.可以在全局配置模式下使用no ip domain-lookup命令關閉它

假如你在你的網絡里有DNS服務器,可以使用1些命令使DNS解析開始工作:

1.第一條命令是:ip domain-lookup,這個命令默認是打開了的.如果你之前使用了no ip domain-lookup的話,就要用這條命令打開它

2.第二條命令是:ip name-server.設置DNS服務器的IP地址,可以使1個IP地址對應多達6個服務器

3.最后條命令是:ip domain-name.雖然這個命令是可選的,但是最好還是設置1下

實例如下:

2500(config)#ip domain-lookup

2500(config)#ip name-server 192.168.0.23

2500(config)#ip domain-name noko.com

2500(config)#^Z

2500#

可以使用ping命令來嚴正下,如下:

2500#ping 1900S

Translating “1900S”…domain server (192.168.0.23) [OK]

(略)

使用show hosts命令驗證下,如下:

2500#sh hosts

Default domain is noko.com

Name/address lookup uses domain service

Name servers are 192.168.023

Host Flags Age Type Address(es)

2501B (perm, OK) 0 IP 172.16.10.2

1900S.noko.com (temp, OK) 0 IP 192.168.0.32

2500#

檢查網絡連接

使用ping命令和Traceroute命令

第十章,  使用訪問列表管理流量

訪問列表可以用于允許或拒絕包通過路由器、允許或拒絕Telnet(VTY)訪問路由器、允許或拒絕來自路由器的Telnet訪問,以及創建可以出發撥號到遠程站點的流量。

訪問列表簡介

訪問列表基本上是一系列對包進行分類的條件。

一個最常用和最容易理解的使用訪問列表的情況是,實現安全策略時過濾不希望通過的包。

數據包和訪問列表向比較時遵循的重要規則:

1.  通常是按順序比較訪問列表的每一行。

2.  比較訪問列表的各行直到比較到匹配的一行。

3.  在每個訪問列表的最后是一行隱含“deny”語句-意味著如果數據包與訪問列表中的所有行都不匹配,將被丟棄。

訪問列表有兩種類型:

1.  標準的訪問列表

2.  擴展的訪問列表

3.  命名的訪問列表(基于標準和擴展之間的)

在一個接口的輸入方向和輸出方向使用不同的訪問列表:

1.  輸入型訪問列表 黨訪問列表被應用刀從接口輸入的包時,那些包在被路由到輸出接口之前要經過訪問列表的處理。

2.  輸出行訪問列表 當訪問列表被應用到從接口輸出的包時,那些包首先被路由到輸出接口,然后在進入該接口的輸入隊列之前經過訪問列表的處理。

標準的訪問列表

標準的IP訪問列表通過使用IP包中的源IP地址過濾網絡流量。可以使用訪問列表號1-99或130-1999創建標準的訪問列表。一般用號碼區別訪問列表類型。

通配符

通配符和訪問列表一起用來指定一個主機、一個網絡、一個網絡或幾個網絡內的某個范圍。

要理解通配符,需要理解什么是塊大小,這里常常指地址范圍。一些有效的塊大小是64、32、16、8和4。

簡單的描述,通配符相當于是子網掩碼,不過剛好相反,0表示絕對匹配,1表示任意匹配。

標準的訪問列表舉例:

Lab_A#config t

Lab_A(config)#access-list 10 deny 172.16.40.0 0.0.0.255

Lab_A(config)#access-list 10 permit any

這個訪問控制列表的意思是,拒絕所有172.16.40.0這個網段的數據

其他的數據都允許通過。

擴展的訪問控制列表

擴展的訪問列表允許指定源地址和目的地址,以及表示上層協議或應用的協議和端口號。通過使用擴展的IP訪問列表,可以有效地允許用戶訪問物理

LAN的同時不允許訪問特定的主機或甚至那些主機上的特定服務。

擴展的訪問列表舉例:

Lab_A#config

Lab_A(config)#access-list 110 deny tcp any host 172.16.30.5 eq 21

Lab_A(config)#access-list 110 deny tcp any host 172.16.30.5 eq 23

Lab_A(config)#access-list 110 permit ip any any

第一行和第二行意思是,拒絕所有目的地址是172.16.30.5的FTP訪問和Telnet訪問

第三行意思是,允許所有的數據通過。

第十一章,              廣域網協議

定義WAN術語:

1.  Customer premises equipment,CPE(用戶駐地設備)

2.  Demarcation point(分界點)

3.  Local loop(本地回路)

4.  Central office(中心局)

5.  Toll network(長途網絡)

WAN連接類型

WAN可以使用許多不同的連接類型,這里只介紹市場上常見的各種WAN連接類型。

1.  專線

2.  電路交換

3.  分組交換

下面解釋WAN連接類型:

1.  租用線路 租用線路典型地指點導電連接或專線連接。

2.  電路交換 電路交換的最大優勢就是成本低。在端到端連接之前不能傳輸數據。電路交換使用撥號調制解調或ISDN,用于低帶寬數據傳輸。

3.  包交換 允許和其他公司共向帶寬以節省資金。如果需要經常傳輸數據,則不咬考慮這種類型,應當使用租用線路。

WAN支持

1.  幀中繼

2.  ISDN

3.  LAPB

4.  HDLC

5.  PPP

6.  ATM

WAN布線

Cisco串行連接幾乎支持WAN服務的任何類型。典型的WAN連接是使用HDLC、PPP、綜合業務數字網和幀中繼專線。

HDLC、PPP和幀中繼可以使用同一種物理規范,但是ISDN在物理層有各種不相同的輸出引腳和規范。

串行傳輸

WAN串行連接器使用串行傳輸,即一個信道一個時間只傳輸一位。

Cisco路由器使用專用的60針串行連接器,這種連接器只能從CiscoCisco設備服務提供商獲得。

電纜另一端的連接器類型依賴于服務提供商或所需的終端設備。

各種可用的設備有:

1.  EIA/TIA-232

2.  EIA/TIA-499

3.  V.35

4.  X.21

5.  EIA-530

數據終端設備(DTE)和數據通信設備(DCE)

路由器接口默認情況下是數據終端設備(DTE),連接著數據通信設備(DCE)。

WAN的思想是能夠通過DCE網絡將兩個DTE網絡連接在一起。

固定接口和模塊化接口

固定接口的路由器,如2500系列,具有不能更換的一套接口。1600、1700、2600、3600以及更高系列的路由器都具有模塊化的接口,即允許你購買現在所需的接口并增加以后可能需要的任何類型的接口。

高級數據鏈路控制協議

HDLC是流行的ISO標準、面向位的數據鏈路層協議。它使用幀特性和效驗和規定數據在同步串行數據鏈路上封裝的方法。HDLC是一種用于租用線路的點到點協議。

在面向字節協議中,用整個字節對控制信息進行編碼。

點到點協議

PPP是一種可以用于異步撥號或同步穿行介質的數據鏈路層協議。他使用LCP建立并維護數據鏈路連接。

PPP包含的主要組件:

EIA/TIA-232-C、V.24、V.35V和ISDN

HDLC

LCP

NCP

鏈路控制協議配置選項

鏈路控制協議提供各種PPP封裝選項:

1.  Authentication(認證)

2.  Compression(壓縮)

3.  Error detection (錯誤檢測)

4.  Multilink(多鏈路)

5.  PPP回叫

PPP會話建立

當PPP連接開始時,連路經過三個會話建立階段:

鏈路建立階段每個PPP設備發送LCP包來配置和測試連路。

認證階段如果配置了認證,在人證鏈路時可以使用CHAP或PAP。認證發生在讀取網絡層協議信息之前。

PPP認證方法

PPP鏈路可以使用兩種認證方法:

口令認證協議(PAP) 口令認證協議是兩種方法中安全程度較低的一種。口令以明文發送,并且PAP值在初始鏈路建立時執行。

問答握手認證協議(CHAP) 問答握手認證協議用于鏈路初始啟動,和為了證實路由器連接的仍然是同一個主機而進行周期性鏈路檢查。

Cisco路由器上配置PPP

Router#config t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#int s0

Router(config-if)#encapsulation ppp

Router(config-if)#^Z

Router#

配置PPP認證

將串行接口配置為支持PPP封裝后,可以使用PPP在路由器之間配置認證。

Router#config t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname RouterA

RouterA(config)#username RouterB password 12345

當使用hostname命令時,要記住用戶名師連接你路由器的遠程路由器的主機名。

當設置了主機名、用戶名和口令后,選擇認證類型、CHAP和PAP:

RouterA#config t

Enter configuration commands, one per line.  End with CNTL/Z.

RouterA(config)#int s0

RouterA(config-if)#ppp authentication chap pap

RouterA(config-if)#^Z

RouterA#

驗證PPP封裝

使用show interface命令來驗證配置。

幀中繼

幀中繼是從x.25技術發展來的。

幀中繼技術簡介

幀中繼是包交換技術。

1.  不能使用encapsulation hdlc或encapsulation ppp命令進行配置。

2.  幀中繼和點到點租用線路不一樣。

3.  幀中繼在許多情況下沒有租用線路昂貴,但未了節省費用會有些損失。

幀中繼技術

首先要知道這種技術的工作原理。

工作過程如下:

1.  用戶網絡主機在本地網絡發送一個幀。

2.  路由器獲得此幀,提取出數據包,丟棄剩下的幀。

3.  路由器然后從它認為可以找到遠程網絡的接口轉發此數據。

4.  信道服務單元/數據服務單元(CSU/DSU)接收數字信號,并將信號編碼為包交換機(PSE)可以理解的數字信號類型。

5.  CSU/DSU連接分界,分解由服務提供商安裝并且位于服務提供商的第一個負責點。

6.  典型的分解時連接到本地回路的雙絞線電纜。

7.  CO接收幀并通過幀中繼“網云”發送到他的目的地。

8.  一旦幀到達最靠近目的交換局,就發送到本地回路上。

承諾信息率(CIR)

幀中繼提供商同時為許多不能得客戶提供包交換網絡。

正中及通過每個用戶提供部分專用帶寬工作,并在電信網絡有可用資源的情況下允許用戶超過他們保證的帶寬。

訪問速率(Access rate) 幀中繼接口可以傳輸的最大速率。

CIR 數據傳輸承諾的最大速率。

幀中繼封裝類型

當在Cisco路由器上配置幀中繼時,需要在串行接口上將幀中繼指定為一種封裝。

RouterA(config)#int s0

RouterA(config-if)#encapsulation frame-relay ?

  ietf  Use RFC1490/RFC2427 encapsulation

  <cr>

除非手的輸入ietf,否則默認的封裝是Cisco,而且連接兩個Cisco設備時使用Cisco類型。

虛電路

幀中繼使用虛電路工作方式,對英語租用線路使用的真正電路。這些虛電路是連接到提供商“網云”上的幾千個設備構成的鏈路。

本地管理接口

本地管理接口是路由器和它所連接的第一個幀中繼交換機之間使用的信令標準。

它傳輸下列有關信息:

1.  保持激活

2.  組播

3.  全局尋址

4.  虛電路狀態

幀中繼擁塞控制

CIR設置的越低,數據被丟棄的危險就越大。

三種擁塞位和其意義:

1.  丟棄合格

2.  向前顯示擁塞通知

3.  向后顯示擁塞通知

幀中繼的試驗和監控

單個接口

RouterA#config

05:41:11: %SYS-5-CONFIG_I: Configured from console by consolet

Enter configuration commands, one per line.  End with CNTL/Z.

RouterA(config)#int s0

RouterA(config-if)#encapsulation frame-relay

RouterA(config-if)#ip addr 172.16.20.1 255.255.255.0

RouterA(config-if)#frame-relay lmi-type ansi

RouterA(config-if)#frame-relay interface-dlci 101

RouterA(config-fr-dlci)#^Z

子接口

可能在一個串行接口上有多條虛電路,并且將每個虛電路視為一個單獨的接口,他被認為是子接口。

可以用int s0.subinterface number命令定義子接口。

點到點

當一個虛電路連接一個路由器到另一個路由時使用點到點子接口。

多點

檔路由器位于星型虛電路的中心時使用多點子接口。

綜合業務數字網

ISDN是一種在現有電話網上運行的數字服務。

PPP典型地用于ISDN,提供數據傳輸、鏈路集成和認證。

ISDN的優勢有:

1.  可以同時承載語音、視頻和數據。

2.  胡椒和建立比模擬調制解調器要快。

3.  數據傳輸率比模擬調制解調器連接要高。

4.  ISDN上的全時連接是由Cisco IOS路由器使用按需撥號路由技術造成的假象。

5.  使用ISDN BRI業務可以非常經濟地支持小型辦公室和家庭辦公室站點。

6.  調制解調器的機架放置和布線問題可以通過在Cisco IOS網絡接入服務器上集成數字調制解調器卡萊解決。

ISDN連接

ISDN是由兩個64K的B信道和一個用于傳輸信令的16K的D信道組成。

ISDN BRI 路由器有一個U接口或一個S/T接口。

ISDN組件

ISDN使用的組件包括功能和參考點。

ISDN終端

連接到ISDN網絡的設備是終端設備(TE)和網絡終端(NT)設備。美中設備有兩種類型:

1.  TE1

2.  TE2

3.  NT1

4.  NT2

5.  TA

ISDN參考點

參考電視一系列規范,定義用于ISDN網絡中的各種設備之間的連接。ISDN有四種定義邏輯接口的參考點:

1.R R參考點定義非ISDN設備(TE2)和TA之間的連接點。

2.S S參考點定義客戶路由器和NT2之間的連接點。

3.T T參考點定義NT1和NT2設備之間的連接點。

4.U U參考點定義NT1設備和載波網絡中的線路終端設備之間的連接點。

基本速率接口

ISDN基本速率接口業務,也叫做2B+D,提供兩個B信道和一個D信道,BRI的總帶寬是144Kb/s

要設置BRI胡椒,必須經過四個步驟:

1.  路由器和本地ISDN交換機之間的D信道連接。

2.  ISDN交換機使用SS7信令技術建立到遠程交換機的路徑。

3.  然后B信道連接端對端。

基群速率接口

ISDN基群速率接口業務提供23個64Kb/s B信道和一個64Kb/s D信道,PRI的總帶寬是2.048Mb/s

ISDN和Cisco路由器

對于每個ISDN BRI接口,需要使用isdn spid1和isdn spid2接口子命令指定SPID。

SPID配置的第二部分是那個SPID的本地撥號號碼。

按需撥號路由選擇

按需撥號路由選擇用于允許兩個或多個Cisco路由器在需要時使用ISDN撥號連接。

當接口接收到數據包符合管理員設定的訪問列表的要求時DDR才工作。

5個步驟基本描述了黨路由器接收到一個觸發DDR的數據包時DDR是如何工作的:

1.  決定通過撥號連接到目的網絡的路由。

2.  觸發DDR的數據包指示一個DDR呼叫。

3.  查找撥號信息并進行撥號。

4.  傳輸流量。

5.  當鏈路上沒有流量并且空閑超時時間到時胡椒結束。

配置DDR

配置DDR,需要執行三個任務:

1.  定義靜態路由,定義如何到達遠程網絡以及通過什么接口到達。

2.  為路由器指定觸發DDR的流量。

3.  配置撥號信息,撥號連接到達遠程網絡的接口時將使用此號碼。

配置靜態路由

創建靜態路由時牢記下列問題:

1.  所有參與的路由器必須都有定義所有已知網絡的靜態路由。

2.  可以在存根網絡中使用默認路由。

創建靜態路由例子:

RouterA(config)#ip route 172.16.50.0 255.255.255.0 172.16.60.2

RouterA(config)#ip route 172.16.60.2 255.255.255.255 bri0

這樣做是告訴路由器通過172.16.60.2可以到達網絡172.16.50.0。第二行告訴路由器如何到達172.16.60.2。

指定觸發DDR的流量

在每個路由器上設置了路由表以后,需要配置路由器決定什么流量啟動ISDN線路。

RouterA(config)#dialer-list 1 protocol ip permit

RouterA(config)#int bri0

RouterA(config-if)#dialer-group 1

Dialer-group在BRI接口上設置訪問列表。

配置撥號信息

配置撥號信息有五個步驟:

1.  選擇接口。

2.  設置IP地址。

3.  配置封裝類型。

4.  在接口上設置觸發DDR的流量。

5.  配置一個或多個撥號號碼。

五個步驟地例子:

RouterA#config

Enter configuration commands, one per line.  End with CNTL/Z.

RouterA(config)#int bri0

RouterA(config-if)#ip addr 172.16.60.1 255.255.255.0

RouterA(config-if)#no shut

RouterA(config-if)#encapsulation ppp

RouterA(config-if)#dialer-group 1

RouterA(config-if)#dialer string 8350661

不用dialer string命令,可以使用Dialer map命令,他提供更好的安全性。

RouterA(config-if)#dialer map ip 172.16.60.2 name RouterB 8350661

Dialer map命令可以和dialer-group命令及其相關的訪問列表一起使用以初始化撥號。

必須知道的五個基本撥號影射步驟是:

1.  Dialer

2.  Map

3.  協議

4.  下一跳

5.  號碼串

可選命令

Dialer load-threshold

Dialer idle-timeout

Dialer load-threshold命令告訴BRI接口什么時候啟用第二個B信道。

Dialer idle-timeout命令指定在發送完最后一個觸發DDR的流量之后到斷開呼叫之前的秒數。

DDR和訪問列表

RouterA(config)#dialer-list 1 protocol ip list 110

RouterA(config)#access-list 110 permit tcp any any eq smtp

RouterA(config)#access-list 110 permit tcp any any eq telnet

RouterA(config)#int bri0

RouterA(config-if)#dialer-group 1

這里不一定必須是IP協議,可以使用任何協議。

創建撥號列表,然后用dialer-group命令應用到BRI接口。

文章出自:CCIE那點事 http://www.qdxgqk.live/ 版權所有。本站文章除注明出處外,皆為作者原創文章,可自由引用,但請注明來源。 禁止全文轉載。
本文鏈接:http://www.qdxgqk.live/?p=409轉載請注明轉自CCIE那點事
如果喜歡:點此訂閱本站
上篇文章:
下篇文章:
  • 相關文章
  • 為您推薦
  • 各種觀點
?
暫時還木有人評論,坐等沙發!
發表評論

您必須 [ 登錄 ] 才能發表留言!

?
?
萌宠夺宝游戏