電力行業思科解決方案!HSRP+負載勻衡

來源:本站原創 CISCO 超過718 views圍觀 0條評論

電力行業思科解決方案!HSRP+負載勻衡親愛的網友們,座在本本前寫出自己的項目經歷,真是一種說不出的喜悅啊!
項目簡介——
今天我要向大家介紹的是廣東省某電力公司采用思科的解決方案組建超級局域網。主要是通過雙4507R來實現雙機熱備和負載勻衡。接入交換機是CISCO-2960-24TC-L
設備簡介——
CISCO-4507R是一款中檔三層路由交換機,有七個插槽,其中第一、二個插槽是用來插引擎滴,千萬不要弄插哦,不然它會痛的。剩下五個插槽全是業務插槽,千兆光口板,千兆電口板等業務板可以隨你插了。
CISCO-2960-24TC-L是一款二層接入交換機,2960系列有多款交換機,24口、48口、百兆、千兆、SFP模塊等,產品線相當豐富,滿足中小型企業的接入需求。
拓撲簡介——
出口是CISCO-2821路由器,這是思科在2006年推出的ISR系列路由器中28系列路由器的中檔配置,滿足企業分支構多種廣域網接入方式,E1,T1,ADSL,FR,寬帶接入等。
從網絡的安全性能考慮,我們給客戶推薦了天融信的防火墻作透明。
通過防火墻下聯兩臺CISCO-4507R做雙機熱備,同時實現負載勻衡。
接入交換機通過光纖冗余接入CISCO-4507R。
實施步驟——
一 完全拓撲連接
二 設備加電、完成設備自檢
三 配置路由器
         配置外網口IP,網關,默認路由,內網各VLAN 網段回執路由
四 配置防火墻
         將防火墻配置成透明模式,實現對包的過濾
五 配置核心交換機
         兩臺設備配置HSRP,所以兩臺4507R的配置幾乎完全一樣。
         創建CHANNEL,將端口加入CHANNEL
         創建VLAN
         給各VLAN 接口配置IP,配置STANDBY的IP,以及STANDBY優先級等參數
         (在這里有一點提醒大家,如果要在HSRP基礎上實現負載勻衡,那么兩臺交換機的配置是稍有不同的。HSRP是一主一次,只有一臺設備轉發包,如果要實現負載勻衡,
         我們就得讓兩臺設備都工作起來。可以通過設備STANDBY的優先級來實現。具體的配置在后面的實例中詳談。)
         配置默認路由指向路由器的內網口IP
         配置TRUNK口,封裝協議
         配置ACL策略
六     配置接入交換機
         配置管理IP
         配置VLAN
         配置TRUNK口
配置文檔——
在這里只貼出4507R的配置
C4507R-S#sh run
Building configuration…
Current configuration : 8888 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service compress-config
!
hostname C4507R-S
!
boot-start-marker
boot-end-marker
!
!
redundancy
mode sso
enable secret 5 $1$mDs3$W6xmvv0ZxWxih3VH.7/ES0   ciscoh3c
enable password cisco
!
no aaa new-model
qos
vtp mode transparent
ip subnet-zero
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
power redundancy-mode redundant
!
!
!
vlan internal allocation policy ascending
!
vlan 9,37-38,40-43,60 -----------(創建VLAN)
!
interface Port-channel1-----------(創建CHENNEL)
switchport
switchport trunk encapsulation dot1q
!
interface GigabitEthernet1/1----------(將端口加入CHENNEL)
switchport trunk encapsulation dot1q
channel-group 1 mode on
!
interface GigabitEthernet1/2----------(將端口加入CHENNEL)
switchport trunk encapsulation dot1q
channel-group 1 mode on
!
interface GigabitEthernet3/5
switchport trunk encapsulation dot1q
switchport mode trunk
ip access-group 100 in
!………………..--------------(將端口配置成TRUNK,并封裝)
…………………--------------(將端口配置成TRUNK,并封裝)
interface GigabitEthernet3/48--------------(將端口配置成TRUNK,并封裝)
switchport trunk encapsulation dot1q
channel-group 1 mode on
!
interface GigabitEthernet5/1--------------(將端口配置成TRUNK,并封裝)
switchport trunk encapsulation dot1q
switchport mode trunk
ip access-group 100 in
……..
……..
……..
interface GigabitEthernet5/18
switchport mode trunk--------------(將端口配置成TRUNK,并封裝)
!
interface Vlan1--------------(配置VLAN 接口)
ip address 172.16.1.252 255.255.255.0--------------(配置VLAN 接口IP)
standby 1 ip 172.16.1.254--------------(配置VLAN 接口STANDBY IP,這才是數據轉發用的實際IP)
standby 1 preempt--------------(配置HSRP允許搶占優先)
standby 1 priority 110-----------------------(HSRP優先級如何不配置默認是100)
!
interface Vlan9
ip address 172.16.9.252 255.255.255.0
standby 9 ip 172.16.9.254
standby 9 preempt-----------------------(HSRP優先級如何不配置默認是100,因為要實現負載勻衡這個VLAN默認優先級)
!…….. ××××××××××××××注意看,VLAN1優先級110,所以它會是VLAN1的STANDBY1組的主,另一臺是備!!!!!!!!
                                             VLAN9優先級100,另一臺是110,所以這臺是備,另一臺是主,由此實現負載勻衡!!!!
………
interface Vlan60
ip address 192.168.60.252 255.255.255.0
standby 60 ip 192.168.60.254
standby 60 preempt
!
ip route 0.0.0.0 0.0.0.0 192.168.60.1--------------(配置默認路由)
no ip http server
!
!--------------(配置ACL策略)
access-list 100 permit tcp 172.16.43.0 0.0.0.255 host 172.16.9.16 eq www
access-list 100 permit tcp 172.16.43.0 0.0.0.255 host 172.16.9.17 eq www
access-list 100 permit tcp 172.16.43.0 0.0.0.255 host 172.16.9.18 eq www
access-list 100 permit ip 172.16.37.0 0.0.0.255 172.16.40.192 0.0.0.15
access-list 100 permit ip 172.16.38.0 0.0.0.255 172.16.40.192 0.0.0.15
access-list 100 permit ip 172.16.41.0 0.0.0.255 172.16.40.192 0.0.0.15
access-list 100 permit ip 172.16.42.0 0.0.0.255 172.16.40.192 0.0.0.15
access-list 100 deny ip 172.16.37.0 0.0.0.255 172.16.40.0 0.0.0.255
access-list 100 deny ip 172.16.37.0 0.0.0.255 172.16.41.0 0.0.0.255
access-list 100 deny ip 172.16.37.0 0.0.0.255 172.16.42.0 0.0.0.255
access-list 100 deny ip 172.16.38.0 0.0.0.255 172.16.37.0 0.0.0.255
access-list 100 deny ip 172.16.38.0 0.0.0.255 172.16.40.0 0.0.0.255
access-list 100 deny ip 172.16.38.0 0.0.0.255 172.16.41.0 0.0.0.255
access-list 100 deny ip 172.16.38.0 0.0.0.255 172.16.42.0 0.0.0.255
access-list 100 deny ip 172.16.41.0 0.0.0.255 172.16.40.0 0.0.0.255
access-list 100 deny ip 172.16.41.0 0.0.0.255 172.16.42.0 0.0.0.255
access-list 100 deny ip 172.16.42.0 0.0.0.255 172.16.40.0 0.0.0.255
access-list 100 deny ip 172.16.43.0 0.0.0.255 192.168.60.0 0.0.0.255
access-list 100 deny ip 172.16.43.0 0.0.0.255 172.16.9.0 0.0.0.255
access-list 100 permit ip any any
!
!
!
line con 0
stopbits 1
line vty 0 4--------------(配置VTY接口)
password cisco
login
line vty 5 15
no login
!
!
end

文章出自:CCIE那點事 http://www.qdxgqk.live/ 版權所有。本站文章除注明出處外,皆為作者原創文章,可自由引用,但請注明來源。 禁止全文轉載。
本文鏈接:http://www.qdxgqk.live/?p=351轉載請注明轉自CCIE那點事
如果喜歡:點此訂閱本站
  • 相關文章
  • 為您推薦
  • 各種觀點
?
暫時還木有人評論,坐等沙發!
發表評論

您必須 [ 登錄 ] 才能發表留言!

?
?
萌宠夺宝游戏