廣域網協議設置三、x.25

來源:本站原創 CISCO 超過771 views圍觀 0條評論

三、x.25

1.??????? X25技術

X.25規范對應OSI三層,X.25的第三層描述了分組的格式及分組交換的過程。X.25的第二層由LAPB(Link Access Procedure, Balanced)實現,它定義了用于DTE/DCE連接的幀格式。X.25的第一層定義了電氣和物理端口特性。

X.25網絡設備分為數據終端設備(DTE)、數據電路終端設備(DCE)及分組交換設備(PSE)。DTE是X.25的末端系統,如終端、計算機或網絡主機,一般位于用戶端,Cisco路由器就是DTE設備。DCE設備是專用通信設備,如調制解調器和分組交換機。PSE是公共網絡的主干交換機。

X.25定義了數據通訊的電話網絡,每個分配給用戶的x.25 端口都具有一個x.121地址,當用戶申請到的是SVC(交換虛電路)時,x.25一端的用戶在訪問另一端的用戶時,首先將呼叫對方x.121地址,然后接收到呼叫的一端可以接受或拒絕,如果接受請求,于是連接建立實現數據傳輸,當沒有數據傳輸時掛斷連接,整個呼叫過程就類似我們撥打普通電話一樣,其不同的是x.25可以實現一點對多點的連接。其中x.121地址、htc均必須與x.25服務提供商分配的參數相同。X.25 PVC(永久虛電路),沒有呼叫的過程,類似DDN專線。

2.??????? 有關命令:

任務

命令

設置X.25封裝

encapsulation x25 [dce]

設置X.121地址

x25 address x.121-address

設置遠方站點的地址映射

x25 map protocol address [protocol2 address2[…[protocol9 address9]]] x121-address [option]

設置最大的雙向虛電路數

x25 htc citcuit-number1

設置一次連接可同時建立的虛電路數

x25 nvc count2

設置x25在清除空閑虛電路前的等待周期

x25 idle minutes

重新啟動x25,或清一個svc,啟動一個pvc相關參數

clear x25 {serial number | cmns-interface mac-address} [vc-number] 3

清x25虛電路

clear x25-vc

顯示接口及x25相關信息

show interfaces serial

show x25 interface

show x25 map

show x25 vc

注:1、虛電路號從1到4095,Cisco路由器默認為1024,國內一般分配為16。

2、虛電路計數從1到8,缺省為1。

3、在改變了x.25各層的相關參數后,應重新啟動x25(使用clear x25 {serial number | cmns-interface mac-address} [vc-number]或clear x25-vc命令),否則新設置的參數可能不能生效。同時應對照服務提供商對于x.25交換機端口的設置來配置路由器的相關參數,若出現參數不匹配則可能會導致連接失敗或其它意外情況。

3.??????? 實例:

3.1. 在以下實例中每二個路由器間均通過svc實現連接。

http://img.bimg.126.net/photo/XQrEb97W5dwN9kjfdyJxig==/449234062847054846.gif

路由器設置如下:

Router1:

interface Serial0

encapsulation x25

ip address 192.200.10.1 255.255.255.0

x25 address 110101

x25 htc 16

x25 nvc 2

x25 map ip 192.200.10.2 110102 broadcast

x25 map ip 192.200.10.3 110103 broadcast

!

Router2:

interface Serial0

encapsulation x25

ip address 192.200.10.2 255.255.255.0

x25 address 110102

x25 htc 16

x25 nvc 2

x25 map ip 192.200.10.1 110101 broadcast

x25 map ip 192.200.10.3 110103 broadcast

!

Router:

interface Serial0

encapsulation x25

ip address 192.200.10.3 255.255.255.0

x25 address 110103

x25 htc 16

x25 nvc 2

x25 map ip 192.200.10.1 110101 broadcast

x25 map ip 192.200.10.2 110102 broadcast

!

相關調試命令

clear x25-vc

show interfaces serial

show x25 map

show x25 route

show x25 vc

3.2. 在以下實例中路由器router1和router2均通過svc與router連接,但router1和router2不通過svc直接連接,此三個路由器的串口運行RIP路由協議,使用了子接口的概念。由于使用子接口,router1和router2均學習到了訪問對方局域網的路徑,若不使用子接口,router1和router2將學不到到對方局域網的路由。

子接口(Subinterface)是一個物理接口上的多個虛接口,可以用于在同一個物理接口上連接多個網。我們知道為了避免路由循環,路由器支持split horizon法則,它只允許路由更新被分配到路由器的其它接口,而不會再分配路由更新回到此路由被接收的接口。

無論如何,在廣域網環境使用基于連接的接口(象 X.25和Frame Relay),同一接口通過虛電路(vc)連接多臺遠端路由器時,從同一接口來的路由更新信息不可以再被發回到相同的接口,除非強制使用分開的物理接口連接不同的路由器。Cisco提供子接口(subinterface)作為分開的接口對待。你可以將路由器邏輯地連接到相同物理接口的不同子接口, 這樣來自不同子接口的路由更新就可以被分配到其他子接口,同時又滿足split horizon法則。

http://img.bimg.126.net/photo/wW0ZUtJ2sih60iog7yBrrw==/5781214546661735581.gif

Router1:

interface Serial0

encapsulation x25

ip address 192.200.10.1 255.255.255.0

x25 address 110101

x25 htc 16

x25 nvc 2

x25 map ip 192.200.10.3 110103 broadcast

!

router rip

network 192.200.10.0

!

Router2:

interface Serial0

encapsulation x25

ip address 192.200.11.2 255.255.255.0

x25 address 110102

x25 htc 16

x25 nvc 2

x25 map ip 192.200.11.3 110103 broadcast

!

router rip

network 192.200.11.0

!

Router:

interface Serial0

encapsulation x25

x25 address 110103

x25 htc 16

x25 nvc 2

!

interface Serial0.1 point-to-point

ip address 192.200.10.3 255.255.255.0

x25 map ip 192.200.10.1 110101 broadcast

!

interface Serial0.2 point-to-point

ip address 192.200.11.3 255.255.255.0

x25 map ip 192.200.11.2 110102 broadcast

!

router rip

network 192.200.10.0

network 192.200.11.0

!

文章出自:CCIE那點事 http://www.qdxgqk.live/ 版權所有。本站文章除注明出處外,皆為作者原創文章,可自由引用,但請注明來源。 禁止全文轉載。
本文鏈接:http://www.qdxgqk.live/?p=347轉載請注明轉自CCIE那點事
如果喜歡:點此訂閱本站
  • 相關文章
  • 為您推薦
  • 各種觀點
?
暫時還木有人評論,坐等沙發!
發表評論

您必須 [ 登錄 ] 才能發表留言!

?
?
萌宠夺宝游戏