廣域網協議設置五、ISDN

來源:本站原創 CISCO 超過802 views圍觀 0條評論

五、ISDN

1.??????? 綜合數字業務網(ISDN)

綜合數字業務網(ISDN)由數字電話和數據傳輸服務兩部分組成,一般由電話局提供這種服務。ISDN的基本速率接口(BRI)服務提供2個B信道和1個D信道(2B+D)。BRI的B信道速率為64Kbps,用于傳輸用戶數據。D信道的速率為16Kbps,主要傳輸控制信號。在北美和日本,ISDN的主速率接口(PRI)提供23個B信道和1個D信道,總速率可達1.544Mbps,其中D信道速率為64Kbps。而在歐洲、澳大利亞等國家,ISDN的PRI提供30個B信道和1個64Kbps D信道,總速率可達2.048Mbps。我國電話局所提供ISDN PRI為30B+D。

2.??????? 基本命令

任務

命令

設置ISDN交換類型

isdn switch-type switch-type1

接口設置

interface bri 0

設置PPP封裝

encapsulation ppp

設置協議地址與電話號碼的映射

dialer map protocol next-hop-address [name hostname] [broadcast] [dial-string]

啟動PPP多連接

ppp multilink

設置啟動另一個B通道的閾值

dialer load-threshold load

顯示ISDN有關信息

show isdn {active | history | memory | services | status [dsl | interface-type number] | timers}

注:1.交換機類型如下表,國內交換機一般為basic-net3。

按區域分關鍵字

交換機類型

Australia

basic-ts013

Australian TS013 switches

Europe

basic-1tr6

German 1TR6 ISDN switches

basic-nwnet3

Norway NET3 switches (phase 1)

basic-net3

NET3 ISDN switches (UK, Denmark, and other nations); covers the Euro-ISDN E-DSS1 signalling system

primary-net5

NET5 switches (UK and Europe)

vn2

French VN2 ISDN switches

vn3

French VN3 ISDN switches

Japan

ntt

Japanese NTT ISDN switches

primary-ntt

Japanese ISDN PRI switches

North America

basic-5ess

AT&T basic rate switches

basic-dms100

NT DMS-100 basic rate switches

basic-ni1

National ISDN-1 switches

primary-4ess

AT&T 4ESS switch type for the U.S. (ISDN PRI only)

primary-5ess

AT&T 5ESS switch type for the U.S. (ISDN PRI only)

primary-dms100

NT DMS-100 switch type for the U.S. (ISDN PRI only)

New Zealand

basic-nznet3

New Zealand Net3 switches

3.??????? ISDN實現DDR(dial-on-demand routing)實例:
設置如下:

Router1:

hostname router1

user router2 password cisco

!

isdn switch-type basic-net3

!

interface bri 0

ip address 192.200.10.1 255.255.255.0

encapsulation ppp

dialer map ip 192.200.10.2 name router2 572

dialer load-threshold 80

ppp multilink

dialer-group 1

ppp authentication chap

dialer-list 1 protocol ip permit

!

Router2:

hostname router2

user router1 password cisco

!

isdn switch-type basic-net3

!

interface bri 0

ip address 192.200.10.2 255.255.255.0

encapsulation ppp

dialer map ip 192.200.10.1 name router1 571

dialer load-threshold 80

ppp multilink

dialer-group 1

ppp authentication chap

dialer-list 1 protocol ip permit

!

Cisco路由器同時支持回撥功能,我們將路由器Router1作為Callback Server,Router2作為Callback Client。

與回撥相關命令:

任務

命令

映射協議地址和電話號碼,并在接口上使用在全局模式下定義的PPP回撥的映射類別。

dialer map protocol address name hostname class classname dial-string

設置接口支持PPP回撥

ppp callback accept

在全局模式下為PPP回撥設置映射類別

map-class dialer classname

通過查找注冊在dialer map里的主機名來決定回撥.

dialer callback-server [username]

設置接口要求PPP回撥

ppp callback request

設置如下:

Router1:

hostname router1

user router2 password cisco

!

isdn switch-type basic-net3

!

interface bri 0

ip address 192.200.10.1 255.255.255.0

encapsulation ppp

dialer map ip 192.200.10.2 name router2 class s3 572

dialer load-threshold 80

ppp callback accept

ppp multilink

dialer-group 1

ppp authentication chap

map-class dialer s3

dialer callback-server username

dialer-list 1 protocol ip permit

!

Router2:

hostname router2

user router1 password cisco

!

isdn switch-type basic-net3

!

interface bri 0

ip address 192.200.10.2 255.255.255.0

encapsulation ppp

dialer map ip 192.200.10.1 name router1 571

dialer load-threshold 80

ppp callback request

ppp multilink

dialer-group 1

ppp authentication chap

dialer-list 1 protocol ip permit

!

相關調試命令

debug dialer

debug isdn event

debug isdn q921

debug isdn q931

debug ppp authentication

debug ppp error

debug ppp negotiation

debug ppp packet

show dialer

show isdn status

舉例:執行debug dialer命令觀察router2呼叫router1,router1回撥router2的過程.

router1#debug dialer

router2#ping 192.200.10.1

router1#

00:03:50: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up

00:03:50: BRI0:1:PPP callback Callback server starting to router2 572

00:03:50: BRI0:1: disconnecting call

00:03:50: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down

00:03:50: BRI0:1: disconnecting call

00:03:50: BRI0:1: disconnecting call

00:03:51: %LINK-3-UPDOWN: Interface BRI0:2, changed state to up

00:03:52: callback to router2 already started

00:03:52: BRI0:2: disconnecting call

00:03:52: %LINK-3-UPDOWN: Interface BRI0:2, changed state to down

00:03:52: BRI0:2: disconnecting call

00:03:52: BRI0:2: disconnecting call

00:04:05: : Callback timer expired

00:04:05: BRI0:beginning callback to router2 572

00:04:05: BRI0: Attempting to dial 572

00:04:05: Freeing callback to router2 572

00:04:05: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up

00:04:05: BRI0:1: No callback negotiated

00:04:05: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up

00:04:05: dialer Protocol up for Vi1

00:04:06: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, changed state

to up

00:04:06: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, chang

ed state to up

00:04:11: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 572

#router1

4.????? ISDN訪問首都在線263網實例:
本地局部網地址為10.0.0.0/24,屬于保留地址,通過NAT地址翻譯功能,局域網用戶可以通過ISDN上263網訪問Internet。263的ISDN電話號碼為2633,用戶為263,口令為263,所涉及的命令如下表:

任務

命令

指定接口通過PPP/IPCP地址協商獲得IP地址

ip address negotiated

指定內部和外部端口

ip nat {inside | outside}

使用ppp/pap作認證

ppp authentication pap callin

指定接口屬于撥號組1

dialer-group 1

定義撥號組1允許所有IP協議

dialer-list 1 protocol ip permit

設定撥號,號碼為2633

dialer string 2633

設定登錄263的用戶名和口令

ppp pap sent-username 263 password 263

設定默認路由

ip route 0.0.0.0 0.0.0.0 bri 0

設定符合訪問列表2的所有源地址被翻譯為bri 0所擁有的地址

ip nat inside source list 2 interface bri 0 overload

設定訪問列表2,允許所有協議

access-list 2 permit any

具體配置如下:

hostname Cisco2503

!

isdn switch-type basic-net3

!

ip subnet-zero

no ip domain-lookup

ip routing

!

interface Ethernet 0

ip address 10.0.0.1 255.255.255.0

ip nat inside

no shutdown

!

interface Serial 0

shutdown

no description

no ip address

!

interface Serial 1

shutdown

no description

no ip address

!

interface bri 0

ip address negotiated

ip nat outside

encapsulation ppp

ppp authentication pap callin

ppp multilink

dialer-group 1

dialer hold-queue 10

dialer string 2633

dialer idle-timeout 120

ppp pap sent-username 263 password 263

no cdp enable

no ip split-horizon

no shutdown

!

ip classless

!

! Static Routes

!

ip route 0.0.0.0 0.0.0.0 bri 0

!

! Access Control List 2

!

access-list 2 permit any

!

dialer-list 1 protocol ip permit

!

! Dynamic NAT

!

ip nat inside source list 2 interface bri 0 overload

snmp-server community public ro

!

line console 0

exec-timeout 0 0

!

line vty 0 4

!

end

5.??????? Cisco765M通過ISDN撥號上263

由于Cisco765的設置命令與我們常用的Cisco路由器的命令不同,所以以下列舉了通過Cisco765上263訪問Internet的具體命令行設置步驟。

>set system c765

c765> set multidestination on

c765> set switch net3

c765> set ppp multilink on

c765> cd lan

c765:LAN> set ip routing on

c765:LAN> set ip address 10.0.0.1

c765:LAN> set ip netmask 255.0.0.0

c765:LAN> set briding off

c765:LAN>cd

c765> set user remotenet

New user remotenet being created

c765:remotenet> set ip routing on

c765:remotenet> set bridging off

c765:remotenet> set ip framing none

c765:remotenet> set ppp clientname 263

c765:remotenet> set ppp password client

Enter new Password: 263

Re-Type new Password: 263

c765:remotenet> set ppp authentication out none

c765:remotenet> set ip address 0.0.0.0

c765:remotenet> set ip netmask 0.0.0.0

c765:remotenet> set ppp address negotiation local on

c765:remotenet> set ip pat on

c765:remotenet> set ip route destination 0.0.0.0/0 gateway 0.0.0.0

c765:remotenet> set number 2633

c765:remotenet> set active

命令描述如下:

任務

命令

設置路由器系統名稱

set system c765

允許路由器呼叫多個目的地

set multidestination on

設置ISDN交換機類型為NET3

set switch net3

允許點到點間多條通道連接實現負載均衡

set ppp multilink on

關掉橋接

set briding off

建立用戶預制文件用于設置撥號連接參數- 可以設置多個用戶預制文件用于相同的物理端口對應于不同的連接。

set user remotenet

使用PPP/IPCP

set ip framing none

設置上網用戶帳號

set ppp clientname 263

設置上網口令

set ppp password client

Enter new Password: 263

Re-Type new Password: 263

不用PPP/CHAP或PAP做認證

set ppp authentication out none

允許地址磋商

set ppp address negotiation local on

設置地址翻譯

set ip pat on

設置默認路由

set ip route destination 0.0.0.0/0 gateway 0.0.0.0

設置ISP的電話號碼

set number 2633

激活用戶預制文件

set active

文章出自:CCIE那點事 http://www.qdxgqk.live/ 版權所有。本站文章除注明出處外,皆為作者原創文章,可自由引用,但請注明來源。 禁止全文轉載。
本文鏈接:http://www.qdxgqk.live/?p=346轉載請注明轉自CCIE那點事
如果喜歡:點此訂閱本站
  • 相關文章
  • 為您推薦
  • 各種觀點
?
暫時還木有人評論,坐等沙發!
發表評論

您必須 [ 登錄 ] 才能發表留言!

?
?
萌宠夺宝游戏