H3C 鏡像配置舉例

來源:本站原創 CISCO 超過861 views圍觀 0條評論

5.1 本地端口鏡像配置舉例1. 組網需求

用戶網絡描述如下:

l????????????? 部門 1的報文通過端口Ethernet1/1接入Device C。

l????????????? 部門 2的報文通過端口Ethernet1/2接入Device C。

l????????????? Server接在Device C的Ethernet1/3端口上。

需求為:用戶希望通過Server對部門 1和部門 2收發的報文進行監控。

使用本地端口鏡像功能實現該需求,在Device C上進行如下配置:

l????????????? 端口Ethernet1/1和Ethernet1/2為鏡像源端口。

l????????????? 連接Server的端口Ethernet1/3為鏡像目的端口。

2. 組網圖

http://img.bimg.126.net/photo/KSlsqzzk74jVvptgRRZ1tA==/449234062847054835.jpg

圖1-4 配置本地端口鏡像組網圖

3. 配置步驟

在Device C上進行如下配置:

# 進入系統視圖。

<DeviceC> system-view

# 創建本地鏡像組。

[DeviceC] mirroring-group 1 local

# 為本地鏡像組配置源端口和目的端口。

[DeviceC] mirroring-group 1 mirroring-port ethernet 1/1 ethernet 1/2 both

[DeviceC] mirroring-group 1 monitor-port ethernet 1/3

# 顯示所有鏡像組的配置信息。

[DeviceC] display mirroring-group all

mirroring-group 1:

type: local

status: active

mirroring port:

Ethernet1/1 both

Ethernet1/2 both

monitor port: Ethernet1/3

配置完成后,用戶就可以在Server上監控部門 1和部門 2收發的所有報文。

1.5.2 遠程端口鏡像配置舉例(配置方式一)1. 組網需求

用戶網絡描述如下:

l????????????? 部門 1的報文通過端口Ethernet1/1接入Device A。

l????????????? 部門 2的報文通過端口Ethernet1/2接入Device A。

l????????????? Device A的Trunk端口Ethernet1/3和Device B的Trunk端口Ethernet1/1相連。

l????????????? Device B的Trunk端口Ethernet1/2和Device C的Trunk端口Ethernet1/1相連。

l????????????? Server接在Device C的Ethernet1/2端口上。

需求為:用戶希望通過Server對部門 1和部門 2收發的報文進行遠程監控。

使用遠程端口鏡像功能實現該需求,進行如下配置:

l????????????? 在Device A上配置遠程源鏡像組,定義VLAN 2為遠程鏡像VLAN,端口Ethernet1/1和Ethernet1/2為鏡像源端口。

l????????????? 配置Device A的Ethernet1/3端口、Device B的Ethernet1/1和Ethernet1/2端口、Device C的Ethernet1/1端口為Trunk端口,并且端口均允許VLAN 2的報文通過。

l????????????? 在Device C上配置遠程目的鏡像組,定義VLAN 2為遠程鏡像VLAN,連接Server的端口Ethernet1/2為鏡像目的端口。

2. 組網圖

 

圖1-5 配置遠程端口鏡像(配置方式一)組網圖

3. 配置步驟

(1)??????? 配置Device A(源設備)

# 進入系統視圖。

<DeviceA> system-view

# 創建遠程源鏡像組。

[DeviceA] mirroring-group 1 remote-source

# 創建VLAN 2。

[DeviceA] vlan 2

[DeviceA-vlan2] quit

# 為遠程源鏡像組配置遠程鏡像VLAN和源端口。

[DeviceA] mirroring-group 1 remote-probe vlan 2

[DeviceA] mirroring-group 1 mirroring-port ethernet 1/1 ethernet 1/2 both

# 配置Ethernet1/3為Trunk端口,并且允許VLAN 2的報文通過。

[DeviceA] interface ethernet 1/3

[DeviceA-Ethernet1/3] port link-type trunk

[DeviceA-Ethernet1/3] port trunk permit vlan 2

(2)??????? 配置Device B(中間設備)

# 進入系統視圖。

<DeviceB> system-view

# 配置Ethernet1/1為Trunk端口,并且允許VLAN 2的報文通過。

[DeviceB] interface ethernet 1/1

[DeviceB-Ethernet1/1] port link-type trunk

[DeviceB-Ethernet1/1] port trunk permit vlan 2

# 配置Ethernet1/2為Trunk端口,并且允許VLAN 2的報文通過。

[DeviceB-Ethernet1/1] interface ethernet 1/2

[DeviceB-Ethernet1/2] port link-type trunk

[DeviceB-Ethernet1/2] port trunk permit vlan 2

(3)??????? 配置Device C(目的設備)

# 進入系統視圖。

<DeviceC> system-view

# 配置Ethernet1/1為Trunk端口,并且允許VLAN 2的報文通過。

[DeviceC] interface ethernet 1/1

[DeviceC-Ethernet1/1] port link-type trunk

[DeviceC-Ethernet1/1] port trunk permit vlan 2

[DeviceC-Ethernet1/1] quit

# 創建遠程目的鏡像組。

[DeviceC] mirroring-group 1 remote-destination

# 創建VLAN 2。

[DeviceC] vlan 2

[DeviceC-vlan2] quit

# 為遠程目的鏡像組配置遠程鏡像VLAN和目的端口。

[DeviceC] mirroring-group 1 remote-probe vlan 2

[DeviceC] interface ethernet 1/2

[DeviceC-Ethernet1/2] mirroring-group 1 monitor-port

[DeviceC-Ethernet1/2] port access vlan 2

配置完成后,用戶就可以在Server上監控部門 1和部門 2收發的所有報文。

文章出自:CCIE那點事 http://www.qdxgqk.live/ 版權所有。本站文章除注明出處外,皆為作者原創文章,可自由引用,但請注明來源。 禁止全文轉載。
本文標題:H3C 鏡像配置舉例
本文鏈接:http://www.qdxgqk.live/?p=339轉載請注明轉自CCIE那點事
如果喜歡:點此訂閱本站
  • 相關文章
  • 為您推薦
  • 各種觀點
?
暫時還木有人評論,坐等沙發!
發表評論

您必須 [ 登錄 ] 才能發表留言!

?
?
萌宠夺宝游戏