CISCO DHCP 配置

來源:本站原創 網絡技術 超過2,023 views圍觀 0條評論

CISCO的路由器(IOS12.0 T1以后),可以配置為dhcp的中繼設備,DHCP的客戶端設備,也可以配置為DHCP的服務器。

Cisco設備上設置DHCP實例
     一位客戶想把DHCP SERVER遷移到6509交換機的MSFC上,要求還挺復雜:
1.同時為多個VLAN的客戶機分配地址
2.VLAN內有部分地址采用手工分配的方式
3.為客戶指定網關、Wins服務器等
4.VLAN 2的地址租用有效期限為1天,其它為3天
5.按MAC地址為特定用戶分配指定的IP地址

最終配置如下:

ip dhcp excluded-address 10.1.1.1 10.1.1.19 //不用于動態地址分配的地址
ip dhcp excluded-address 10.1.1.240 10.1.1.254
ip dhcp excluded-address 10.1.2.1 10.1.2.19
!
ip dhcp pool global //global是pool name, 由用戶指定
network 10.1.0.0 255.255.0.0 //動態分配的地址段
domain-name client.com //為客戶機配置域后綴
dns-server 10.1.1.1 10.1.1.2 //為客戶機配置dns服務器
netbios-name-server 10.1.1.5 10.1.1.6 //為客戶機配置wins服務器
netbios-node-type h-node //為客戶機配置節點模式(影響名稱解釋的順利,如h-node=先通過wins服務器解釋…)
lease 3 //地址租用期限: 3天
ip dhcp pool vlan1
network 10.1.1.0 255.255.255.0 //本pool是global的子pool, 將從global pool繼承domain-name等option
default-router 10.1.1.100 10.1.1.101 //為客戶機配置默認網關
!
ip dhcp pool vlan2 //為另一VLAN配置的pool
network 10.1.2.0 255.255.255.0
default-router 10.1.2.100 10.1.2.101
lease 1
!
ip dhcp pool vlan1_john //總是為MAC地址為…的機器分配…地址
host 10.1.1.21 255.255.255.0
client-identifier 010050.bade.6384 //client-identifier=01加上客戶機網卡地址
!
ip dhcp pool vlan1_tom
host 10.1.1.50 255.255.255.0
client-identifier 010010.3ab1.eac8

相關的DHCP調試命令:
no service dhcp //停止DHCP服務[默認為啟用DHCP服務]
sh ip dhcp binding //顯示地址分配情況
show ip dhcp conflict //顯示地址沖突情況
debug ip dhcp server {events | packets | linkage} //觀察DHCP服務器工作情況

如果DHCP客戶機分配不到IP地址,常見的原因有兩個。第一種情況是沒有把連接客戶機的端口設置為Portfast方式。MS客戶機開機后檢查網卡連接正常,Link是UP的,就開始發送DHCPDISCOVER請求,而此時交換機端口正在經歷生成樹計算,一般需要30-50秒才能進入轉發狀態。MS客戶機沒有收到DHCP SERVER的響應就會給網卡設置一個169.169.X.X的IP地址。解決的方法是把交換機端口設置為Portfast方式:CatOS(4000/5000/6000): set spantree portfast mod_num/port_num enable; IOS(2900/3500): interface … ; spanning-tree portfast。

另外一種情況是DHCP服務器和DHCP工作站不在同一個VLAN,這時候通常通過設置ip helper-address來解決:

interface vlan1
ip address 10.1.1.254 255.255.255.0 //假設DHCP服務器地址為10.1.1.8
interface Vlan2
ip address 10.1.2.254 255.255.255.0
ip helper-address 10.1.1.8 //假設這是DHCP客戶機所在的VLAN

1.  使用IP Helper Addresses命令
提問 配置路由器對DHCP Request轉發的支持
回答
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#interface Ethernet0
Router1(config-if)#ip helper-address 172.25.1.1
Router1(config-if)#ip helper-address 172.25.10.7
Router1(config-if)#exit
Router1(config)#end
Router1#
注釋 使用IP Helper Address命令把路由器配置成為一個DHCP代理服務器,轉發客戶端的DHCP Request至配置的ip helper address。
2.  限制IP Helper Addresses命令的影響
提問 配置IP Helper Address命令以后導致鏈路利用率增高或者DHCP服務器負荷增高
回答
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#no ip forward-protocol udp tftp
Router1(config)#no ip forward-protocol udp nameserver
Router1(config)#no ip forward-protocol udp domain
Router1(config)#no ip forward-protocol udp time
Router1(config)#no ip forward-protocol udp netbios-ns
Router1(config)#no ip forward-protocol udp netbios-dgm
Router1(config)#no ip forward-protocol udp tacacs
Router1(config)#end
Router1#
注釋 缺省情況下IP Helper命令會轉發很多UDP廣播數據包,不僅僅是DHCP數據包,并且不能針對不同的服務器轉發不同的廣播包
3.  使用DHCP來動態配置路由器IP地址
提問 配置路由器動態獲得IP地址
回答
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#interface FastEthernet0/1
Router1(config-if)#ip address dhcp
Router1(config-if)#end
Router1#
Interface FastEthernet0/1 assigned DHCP address 172.25.1.57, mask 255.255.255.0
Router1#
注釋 在12.2(8)T之前此命令僅僅適用于以太網接口。從12.3(8)T以后可以對DHCP選項進行控制,下例配置為不獲得DNS服務器
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#interface FastEthernet0/1
Router1(config-if)#no ip dhcp client request dns-nameserver
Router1(config-if)#end
另外對于獲得的缺省路由,管理距離為254
S*   0.0.0.0/0 [254/0] via 172.25.1.1
從12.3(4)T開始增加了對獲得地址釋放和重新獲得的支持
Router1#release dhcp FastEthernet0/1
Router1#renew dhcp FastEthernet0/1
4.  通過DHCP來對客戶端進行動態IP地址分配
提問 配置路由器成為DHCP服務器
回答
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#service dhcp
Router1(config)#ip dhcp pool 172.25.1.0/24
Router1(dhcp-config)#network 172.25.1.0 255.255.255.0
Router1(dhcp-config)#default-router 172.25.1.1
Router1(dhcp-config)#dns-server 172.25.1.1 202.102.152.3
Router1(dhcp-config)#exit
Router1(config)#ip dhcp excluded-address 172.25.1.1 172.25.1.50
Router1(config)#ip dhcp excluded-address 172.25.1.200 172.25.1.255
Router1(config)#end
Router1#
注釋 注意的是要配置excluded命令來排除某些地址,防止出現地址沖突
5.  配置DHCP的配置選項
提問 配置更多的DHCP配置選項提供給客戶端
回答
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#ip dhcp pool ORAserver
Router1(dhcp-config)#host 172.25.1.34 255.255.255.0
Router1(dhcp-config)#client-name bigserver
Router1(dhcp-config)#default-router 172.25.1.1 172.25.1.3
Router1(dhcp-config)#domain-name oreilly.com
Router1(dhcp-config)#dns-server 172.25.1.1 10.1.2.3
Router1(dhcp-config)#netbios-name-server 172.25.1.1
Router1(dhcp-config)#netbios-node-type h-node
Router1(dhcp-config)#option 66 ip 10.1.1.1
Router1(dhcp-config)#option 33 ip 192.0.2.1 172.25.1.3
Router1(dhcp-config)#option 31 hex 01
Router1(dhcp-config)#lease 2
Router1(dhcp-config)#exit
Router1(config)#end
Router1#
注釋 Option 66 定義TFTP服務器; Option 33定義靜態路由; Option 31定義客戶端使用IRDP.
6.  配置DHCP的分配時長
提問 修改缺省DHCP分配時長
回答
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#ip dhcp pool 172.25.2.0/24
Router1(dhcp-config)#lease 2 12 30
Router1(dhcp-config)#exit
Router1(config)#end
Router1#
注釋 缺省分配為一天,配置選項為天,小時,分鐘
7.  分配靜態IP地址
提問 每次都分配給某個特定設備特定IP地址
回答
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#ip dhcp pool IAN
Router1(dhcp-config)#host 172.25.1.33 255.255.255.0
Router1(dhcp-config)#client-identifier 0100.0103.85e9.87
Router1(dhcp-config)#client-name win2k
Router1(dhcp-config)#default-router 172.25.1.1
Router1(dhcp-config)#domain-name oreilly.com
Router1(dhcp-config)#dns-server 172.25.1.1
Router1(dhcp-config)#exit
Router1(config)#end
Router1#
注釋 這里通過MAC地址來綁定某個IP地址。Client-identifier后面跟的是MAC地址,不過比傳統MAC地址多了0100,代表是以太網,對于更多的媒介類型值參考RFC 3232中的Number Hardware Type部分
Router1#show ip dhcp binding
IP address       Hardware address        Lease expiration        Type
172.25.1.33      0100.0103.85e9.87       Infinite                Manual
172.25.1.52      0100.50da.2a5e.a2       Apr 11 2006 09:00 PM    Automatic
172.25.1.53      0100.0103.ea1b.ed       Apr 11 2006 08:58 PM    Automatic
8.  配置一個DHCP 數據庫客戶端
提問 在另一個設備上備份當前的DHCP數據庫
回答
FTP方式
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#ip dhcp database ftp://dhcp:[email protected]/dhcp-leases
Router1(config)#end
Router1#
TFTP 方式
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#ip dhcp database tftp://172.25.1.1/dhcp-leases
Router1(config)#end
Router1#
RCP方式
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#ip dhcp database rcp://[email protected]/dhcp-leases
Router1(config)#end
Router1#
注釋 通常DHCP數據庫保存于內存,如果重啟就會丟失,可以使用上述方式進行備份從而不會丟失,通過下述命令驗證
Router1#show ip dhcp database
URL      : ftp://dhcp:[email protected]/dhcp-leases
Read     : Never
Written  : Apr 09 2006 10:24 PM
Status   : Last write succeeded. Agent information is up-to-date.
Delay    : 300 seconds
Timeout  : 300 seconds
Failures : 1
Successes: 30
9.  在同一子網配置多個DHCP服務器
提問 在同一子網配置多個DHCP服務器來增加可用性
回答
Router1:
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#ip dhcp pool 172.22.1.0/24
Router1(dhcp-config)#network 172.22.1.0 255.255.255.0
Router1(dhcp-config)#default-router 172.22.1.1
Router1(dhcp-config)#domain-name oreilly.com
Router1(dhcp-config)#dns-server 172.25.1.1 10.1.2.3
Router1(dhcp-config)#exit
Router1(config)#ip dhcp excluded-address 172.22.1.1 172.22.1.49
Router1(config)#ip dhcp excluded-address 172.22.1.150 172.22.1.254
Router1(config)#ip dhcp database ftp://dhcp:[email protected]/dhcp-leases-rtr1
Router1(config)#end
Router1#
Router2:
Router2#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router2(config)#ip dhcp pool 172.22.1.0/24     
Router2(dhcp-config)#network 172.22.1.0 255.255.255.0
Router2(dhcp-config)#default-router 172.22.1.1      
Router2(dhcp-config)#domain-name oreilly.com        
Router2(dhcp-config)#dns-server 172.25.1.1 10.1.2.3 
Router2(dhcp-config)#exit
Router2(config)#ip dhcp excluded-address 172.22.1.1 172.22.1.149
Router2(config)#ip dhcp database ftp://dhcp:[email protected]/dhcp-leases-rtr2
Router2(config)#end
Router2#

10.  DHCP靜態映射
提問 根據某個文本文件來進行IP地址的靜態指配
回答
先在TFTP服務器上創建此文本文件
Freebsd% cat /tftpboot/dhcp.static
*time* Aug 17 2006 03:52 PM
*version* 2
!IP address       Type      Hardware address               Lease expiration
10.1.1.16 /24    id        0100.104b.33da.74                Infinite
10.1.1.17 /24    id        0100.0dbc.eff6.38                Infinite
10.1.1.18 /24    id        0100.0a5e.4001.27                Infinite
10.1.1.19 /24    id        0100.0331.327e.41                Infinite
10.1.1.20 /24    id        0100.0d60.b21a.4c                Infinite
*end*
Freebsd%
路由器配置
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#ip dhcp pool OREILLY
Router1(dhcp-config)#origin file tftp://172.25.1.1/dhcp.static
Router1(dhcp-config)#default-router 10.1.1.1
Router1(dhcp-config)#dns-server 172.25.1.1 172.25.1.3
Router1(dhcp-config)#domain-name oreilly.com
Router1(dhcp-config)#lease 3
Router1(dhcp-config)#end
Router1#
注釋 7講到的靜態地址分配需要一個特定的DHCP Pool,擴展性不強,從12.3(11)T以后可以使用特定的文本文件來進行指配,不過必須遵照一定的格式。如果文本文件修改后需要生效,必須先no service dhcp 來停止DHCP服務然后service dhcp 命令重新啟用來生效
<!–[if !supportLists]–>20.11.       <!–[endif]–>安全DHCP IP地址指派
提問 同步ARP和DHCP地址綁定來防止出現IP地址欺騙
回答
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#ip dhcp pool OREILLY
Router1(dhcp-config)#update arp
Router1(dhcp-config)#end
Router1#
注釋 從12.2(15)T開始思科引入了安全DHCP IP地址指派(DHCP secured IP address assignment),啟用此特性后會針對每個DHCP綁定增加一個安全ARP條目,從而防止對此條目的修改,即使使用clear arp-cache命令也會保證此條目不被清除

11.  顯示DHCP狀態
提問 顯示DHCP服務器的狀態
回答
顯示綁定和相應的分配時長
Router1#show ip dhcp binding
顯示地址沖突
Router1#show ip dhcp conflict
顯示數據庫狀態
Router1#show ip dhcp database
顯示全局DHCP數據統計
Router1#show ip dhcp server statistics
注釋
Router1#show ip dhcp server statistics
Memory usage         17996
Address pools        4
Database agents      1
Automatic bindings   2
Manual bindings      1
Expired bindings     3
Malformed messages   0
Message              Received
BOOTREQUEST          0
DHCPDISCOVER         63
DHCPREQUEST          203
DHCPDECLINE          1
DHCPRELEASE          27
DHCPINFORM           19
Message              Sent
BOOTREPLY            0
DHCPOFFER            63
DHCPACK              139
DHCPNAK              2
Router1#
<!–[if !supportLists]–>20.13.       <!–[endif]–>DHCP排錯
提問 對DHCP出現的問題進行排錯
回答
Router1#debug ip dhcp server events
Router1#debug ip dhcp server packet

文章出自:CCIE那點事 http://www.qdxgqk.live/ 版權所有。本站文章除注明出處外,皆為作者原創文章,可自由引用,但請注明來源。 禁止全文轉載。
本文標題:CISCO DHCP 配置
本文鏈接:http://www.qdxgqk.live/?p=3372轉載請注明轉自CCIE那點事
如果喜歡:點此訂閱本站
  • 相關文章
  • 為您推薦
  • 各種觀點
?
暫時還木有人評論,坐等沙發!
發表評論

您必須 [ 登錄 ] 才能發表留言!

?
?
萌宠夺宝游戏