SLA&EEM 檢測MSTP線路加快路由收斂

來源:本站原創 網絡技術 超過1,577 views圍觀 0條評論

首先介紹下背景:客戶單位的網點目前使用的線路是SDH+FR,網點到地市核心使用的路由協議為RIP,根據實際測試,出現鏈路故障時,不做任何優化的情況下路由收斂需要4分鐘。客戶單位有計劃將網點的FR線路升級為MSTP。
      眾所周知,MSTP線路如果在中間某一點出現故障,是不會導致設備物理端口出現協議層down的。物理接口處于UP狀態時,路由是不會進行收斂的。為了避免此種情況,并加快網絡收斂速度,思科工程師建議使用IP SLA+EEM。于是使用兩臺Cisco2801進行模擬測試,使用的IOS為c2801-entbasek9-mz.150-1.M.bin。
     模擬拓撲如下:
     設備的主要配置如下:
     R1:
hostname R1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$HYYK$evVsS7tjNc5JkX/VuIhCE0
!
no aaa new-model
no network-clock-participate wic 1
dot11 syslog
ip source-route
!
!
!         
!
ip cef
no ip domain lookup
multilink bundle-name authenticated
!
!
!
!
!
archive
log config
  hidekeys
!
!
controller E1 0/1/0
line-termination 75-ohm
channel-group 0 unframed
!
!
track 1 ip sla 1
!
!
!         
!
interface Loopback0
ip address 56.16.0.1 255.255.255.0
!
interface Loopback1
ip address 56.16.128.1 255.255.255.0
!
interface FastEthernet0/0
ip address 56.16.234.1 255.255.255.252
speed 100
full-duplex
!
interface FastEthernet0/1
speed 100
full-duplex
!
interface Serial0/1/0:0
ip address 56.16.244.1 255.255.255.252
!
router rip
version 2
offset-list 0 in 3 Serial0/1/0:0
offset-list 0 out 3 Serial0/1/0:0
network 56.0.0.0
no auto-summary
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
ip route 56.16.234.2 255.255.255.255 FastEthernet0/0
!
ip sla 1
icmp-echo 56.16.234.2
frequency 5
ip sla schedule 1 life forever start-time now
disable-eadi
!
tftp-server flash:c2801-entbasek9-mz.150-1.M.bin
!

scheduler allocate 20000 1000
event manager environment 1
event manager applet rip_track_1
event track 1 state down
action 1.0 cli command "enable"
action 2.0 cli command "conf t"
action 3.0 cli command "int f 0/0"
action 3.1 cli command "shut"   //shut物理端口后,路由表就會發生變化,原本從F0/0學到的路由刪除,取而代之的是從S0/1/0:0學到的路由
action 3.2 cli command "no sh" //執行no shut命令是為了避免MSTP鏈路恢復了,端口仍處于關閉狀態。反正MSTP線路故障不恢復的話就算UP了,也收不到路由更新。
action 4.0 cli command "end"
!
end
R2:
hostname R2
!

!
track 1 ip sla 1
!
!
!
!         
interface Loopback0
ip address 56.26.0.1 255.255.255.0
!
interface Loopback1
ip address 56.26.128.1 255.255.255.0
!
interface FastEthernet0/0
ip address 56.16.234.2 255.255.255.252
speed 100
full-duplex
!
interface FastEthernet0/1
speed 100
full-duplex
!
interface Serial0/1/0:0
ip address 56.16.244.2 255.255.255.252
!
router rip
version 2
offset-list 0 in 3 FastEthernet0/1
offset-list 0 out 3 FastEthernet0/1
network 56.0.0.0
no auto-summary
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
ip route 56.16.234.1 255.255.255.255 FastEthernet0/0
!
ip sla 1
icmp-echo 56.16.234.1
frequency 5
ip sla schedule 1 life forever start-time now
disable-eadi

scheduler allocate 20000 1000
event manager environment 1
event manager applet rip_track_2
event track 1 state down
action 1.0 cli command "enable"
action 2.0 cli command "conf t"
action 3.0 cli command "int f 0/0"
action 3.1 cli command "shut"
action 3.2 cli command "no sh"
action 4.0 cli command "end"
!
end   
當兩個交換機之間的連線拔掉之后,track 1 可以發現56.16.234.2無法ping到,SLA狀態轉為down,觸發了EEM,執行EEM定義的語句。
*Jan  9 05:58:40.911: %TRACKING-5-STATE: 1 ip sla 1 state Up->Down
*Jan  9 05:58:40.995: %SYS-5-CONFIG_I: Configured from console by  on vty0 (EEM:rip_track_1)
*Jan  9 05:58:42.963: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
再查看路由表時,路由已經是從S0/1/0:0學習到的。在配置中的探測頻率與延時情況下,粗略判斷路由收斂的時間在5秒左右,比自行收斂快數十倍。
其中有一個需要注意到地方是配置中的那條主機路由:ip route 56.16.234.2 255.255.255.255 FastEthernet0/0
用于確保探測對端地址的ICMP報文只能從F0/0發出,避免ICMP探測報文從其他路徑到達目標,造成誤判。

文章出自:CCIE那點事 http://www.qdxgqk.live/ 版權所有。本站文章除注明出處外,皆為作者原創文章,可自由引用,但請注明來源。 禁止全文轉載。
本文鏈接:http://www.qdxgqk.live/?p=3257轉載請注明轉自CCIE那點事
如果喜歡:點此訂閱本站
  • 相關文章
  • 為您推薦
  • 各種觀點
?
暫時還木有人評論,坐等沙發!
發表評論

您必須 [ 登錄 ] 才能發表留言!

?
?
萌宠夺宝游戏