思科BFD協議幫助偵測網絡失敗

來源:本站原創 網絡技術 超過2,516 views圍觀 0條評論

Bidirectional Forwarding Detection (BFD) 顧名思義為雙向偵測協議,只檢測與下一跳設備設備連接狀態。目前只在7200以上系列路由器千兆以太接口以上支持,并支持OSPF、ERGRP、ISIS、BGP協議。當客戶端協議建立后,將告訴BFD協議去檢測鄰接連接狀態。BFD檢測包在CEF中具有高的優先級,并且通過unicast形式相互傳播。
FIGURE 1 When OSPF discovers a neighbor (step 1) it sends a request to the local BFD process to initiate a BFD neighbor session with the OSPF neighbor router (step 2). The BFD neighbor session with the OSPF neighbor router is established (step 3).
FIGURE 2 When a failure occurs in the network (step 1), the BFD neighbor session with the OSPF neighbor router is torn down (step 2). BFD notifies the local OSPF process that the BFD neighbor is no longer reachable (step 3). The local OSPF process tears down the OSPF neighbor relationship (step 4)
配置

可以應用到所有接口上
router ospf 1

[no] bfd all-interfaces
也可以應用在單個接口上
[no] ip ospf bfd [disable]



例子
Configuration for Router A

interface Ethernet2/0

ip address 172.16.10.1 255.255.0.0

bfd interval 50 min_rx 50 multiplier 3

!

router ospf 1

log-adjacency-changes detail

network 172.16.0.0 0.0.255.255 area 0

bfd all-interfaces

Configuration for Router B

interface Ethernet1/0

ip address 172.16.10.2 255.255.0.0

bfd interval 50 min_rx 50 multiplier 3

!

router ospf 1

log-adjacency-changes detail

network 172.16.0.0 0.0.255.255 area 0

bfd all-interfaces

顯示本地狀態
RouterA#sh ip ospf int e2/0

Ethernet2/0 is up, line protocol is up

Internet Address 172.16.10.1/16, Area 0
Process ID 1, Router ID 172.16.10.1, Network Type BROADCAST, Cost: 10

Transmit Delay is 1 sec, State BDR, Priority 1,BFD enabled

Designated Router (ID) 172.16.10.2, Interface address 172.16.10.2

Backup Designated router (ID) 172.16.10.1,Interface address 172.16.10.1

Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

查看鄰居狀態 show ip ospf neighbor
RouterA#sh ip ospf nei 172.16.10.2 det

Neighbor 172.16.10.2, interface address 172.16.10.2

In the area 0 via interface Ethernet2/0, BFD enabled

Neighbor priority is 1, State is FULL, 6 state changes

文章出自:CCIE那點事 http://www.qdxgqk.live/ 版權所有。本站文章除注明出處外,皆為作者原創文章,可自由引用,但請注明來源。 禁止全文轉載。
本文鏈接:http://www.qdxgqk.live/?p=308轉載請注明轉自CCIE那點事
如果喜歡:點此訂閱本站
  • 相關文章
  • 為您推薦
  • 各種觀點
?
暫時還木有人評論,坐等沙發!
發表評論

您必須 [ 登錄 ] 才能發表留言!

?
?
萌宠夺宝游戏