思科rip技術詳解

來源:本站原創 網絡技術詳解 超過1,959 views圍觀 0條評論

RIP

介紹:RIP協議的處理是通過UDP 520端口來操作的,所有的RIP消息都被封裝在UDP數據報文中,其中數據報文的源和目的端口字段被設置為520。RIP定義了兩種消息類型:請求消息(request messages)和響應消息(response messages)請求消息用來向鄰居路由器發送一個更新,響應消息用來傳路由更新。RIP的度量是基于“跳數”的,1跳表示的是與發出通告的路由器相直連的網絡,16跳表示網絡不可到達。

工作原理:開始時,RIP從每個啟動RIP協議的接口廣播出帶有請求消息的數據包,接著,RIP程序進入一個循環狀態,不斷地監聽來自其他的路由器的RIP請求或響應消息,而接收請求的鄰居路由器則回送包含它們的路由表的響應消息。當發出請求的路由收到響應消息時,它將開始處理附加在響應消息中的路由更新信息,如果路由更新中的路由條目是新的,路由器則將新的路由連同通告路由器的地址一起加入到自己的路由選擇表中,這里通告路由器的 地址可以從更新數據包的源地址字段讀出如果網絡路由已經在路由選擇表中存在,那么只有在新的路由擁有更小的跳數據時才能替換原來存在的路由條目。如果路由更新通告的跳數大于路由選擇表已記錄的跳數,并且更新來自于已記錄條目的下一跳路由器,那么該路由將在一個指定的抑制時間段(hold down period)內被標記為不可到達,如果在抑制時間超時后,同一個鄰居路由器仍然通告這個有較大跳數的路由,路由器則接受該路由新的度量值。

計時器和穩定性:

1,Update time 缺省是30s 異步更新為25—35 同步更新為25–30

2,Invalid time(無效計時器) 180s 如果3次都沒有收到update 路由條目down 還可以轉發數據包的

3,Flush 240s Invalid 180s 后,再過60s(這60s是在發3次毒性路由)刪除路由條目

4,Hold time 180s 收到的路由條目比原來的路由條目METRIC值大我不更新我的路由條目等待180s中 如果又收到路由條目就更新

RIP使用帶毒性逆轉,水平分隔和觸發更新,不像普通的定期的更新,觸發更新在只要有路由的度量值發生改變時就會產生,而且觸發更新不會引起接收路由器重置綜們的更新計時器;因為如果這么做的話,網絡拓撲的改變會導致很多路由器在同一時間重置,從而引起定其的路由更新變得同步。為了避免拓撲改變后造成觸發更新“風暴”,還需要使用另外一個計時器。當一個觸發更新傳播時,這個計時器被隨機的設置為1~5s之間的數值;在這個計時器計時超過前不能發送并發的觸發更新。

一些主機可以在“靜”模式下使用RIP,這些所謂的“靜”主機不產生RIP的更新報文,而只偵聽RIP的更新消息,從而更新它們自己的路由選擇表。

RIP的消息格式(RIP message format)RIPv1

RIP消息頭部(4個字節),每個條目占用20個字(最多可以容納25條),8個字節的UDP頭部,所以RIP數據報文的大小最大可達512個字節

命令(command)—-只取值1或2,1表示是請求消息,2 表示是響應消息,其他取值都不被使用或保留作私有用途。

版本號(version)—-對于RIPv1,該字段的值設置為1。

地址族標識(address family identifier, AFI)—-對于IP該項設置為2,只有一個例外情況下該消息是路由器(或主機)整個路由選擇表的請求。

IP地址(IP address)—-路由的目的地址,這一項可以是主網絡地址,子網地址或主機路由地址。

度量(metric)—-跳數1~16

RIP的消息格式(RIP message format)RIPv2

RIPv1有的RIPv2都有,在RIPv1的基礎上加了以下這些:

路由標志(route tag)—-提供這個字段用來標記外部路由或重分配到RIPv2協議中的路由,默認的情況下是使用這個16位的字段來攜帶從外部路由選擇協議注入到RIP中的路由的自主系統號。

下一跳(next top)—–如果存在的話,它標識一個比通告路由器地址更好的下一跳地址。

有類別路由選擇

它的一個基本特性就是,宣告網絡地址的時候不能把它的掩碼也宣告出去,因此,有類別路由選擇協議首先必須匹配一個目的地址對應A,B,C類的主網絡號,對于每一個通過路由器的數據包:1,如果目的地址是一個路由器直接相連的主網絡的成員,那么該網絡的路由器接口上配置的子網掩碼將被用來確定目的的地址的子網,因此,在那個主網絡中必須自始至終地統一使用這個相同的子網掩碼。2,如果目的地址不是一個和路由器直接相連的主網絡的成員,那么路由器將僅僅嘗試去匹配該目的的地址對應于A類,B類或C類的主網絡號。

被動接口:

被動接口就是一個RIP網絡中有一個路由器1啟用了RIP協議,而它沒有把接口地址宣告進去,但是它還是能更新自己的路由表,但是這個接口會向直連它的路由器2發廣播包,為了阻塞廣播包可以在路由器2的RIP協議下加上這條命令:passive-interface。這樣就可以把這個路由器1做為一個“靜”主機看待,不發路由更新,只偵聽特定的鏈路上的RIP廣播,從而更新自己的路由表。

命令:

R1(config-router)#neighbor 192.168.10.2 手動配置鄰居,在路由器是“靜”主機的情況下,可以交換RIP通告信息

R1#debug ip rip events 簡要地顯示路由器收發的RIP信息。

特點:

交換是自已的路由表,全部路由條目

負載均衡最多支持6條,默認的是4條

自動匯總默認的是開著的

RIPv1 (有類路由協議)

網絡號

METRIC

下一跳 數據包的源IP

廣播地址:255.255.255.255

自動匯總,不支持手動匯總

不支持認證

不支持VLMS產生CIDR

RIPv2(無類路由協議)

網絡號

METRIC

子網掩碼 (無類路由協議)不產生CIDR

下一跳 (0.0.0.0 —>數據包的源IP)

組播地址:224.0.0.9

支持手工匯總

支持認證

RIPv2和RIPv1 兼容性

RIPv2的報文在RIPv1中不能識別,會被丟棄,而RIPv1的報文在RIPv2中可以識別。RIPv2在RIPv1中使用RIPv2使用廣播方式代替組播方式來通告消息,以便RIPv1可以接收它們。RIPv2在RIPv2中使用組播方式通告消息到目的地址224.0.0.9。

RIP的不足之處:

(1)過于簡單,以跳數為依據計算度量值,經常得出非最優路由。例如:2跳64K專線,和3跳1000M光纖,顯然多跳一下沒什么不好。

(2)度量值以16為限,不適合大的網絡。解決路由環路問題,16跳在rip中被認為是無窮大,rip是一種域內路由算法自治路由算法,多用于園區網和企業網。

(3)安全性差,接受來自任何設備的路由更新。無密碼驗證機制,默認接受任何地方任何設備的路由更行。不能防止惡意的rip欺騙。

(4)不支持無類ip地址和VLSM<ripv1>。

(5)收斂性差,時間經常大于5分鐘。

(6)消耗帶寬很大。完整的復制路由表,把自己的路由表復制給所有鄰居,尤其在低速廣域網鏈路上更以顯式的全量更新。

配置:

實驗目的:讓所有路由器上的環回口通過運行RIP協議可以互相通信。

R1(config)#int f0/0

R1(config-if)#ip address 192.168.12.1 255.255.255.0

R1(config-if)#no shut

R1(config)#int lo 0 創建環回口

R1(config-if)#ip address 1.1.1.1 255.255.255.255

R1(config)#router rip 創建RIP協議

R1(config-router)#version 2 版本號為2

R1(config-router)#no auto-summary 關閉自動匯總

R1(config-router)#network 192.168.12.0 地址宣告進RIP

R2(config)#int f0/0

R2(config-if)#ip address 192.168.22.1 255.255.255.0

R2(config-if)#no shut

R2(config)#int lo 0 創建環回口

R2(config-if)#ip address 2.2.2.2 255.255.255.255

R2(config)#router rip 創建RIP協議

R2(config-router)#version 2 版本號為2

R2(config-router)#no auto-summary 關閉自動匯總

R2(config-router)#network 192.168.22.0 地址宣告進RIP

R3(config)#int f0/0

R3(config-if)#ip address 192.168.32.1 255.255.255.0

R3(config-if)#no shut

R3(config)#int lo 0 創建環回口

R3(config-if)#ip address 3.3.3.3 255.255.255.255

R3(config)#router rip 創建RIP協議

R3(config-router)#version 2 版本號為2

R3(config-router)#no auto-summary 關閉自動匯總

R3(config-router)#network 192.168.32.0 地址宣告進RIP

R4(config)#int f0/0

R4(config-if)#ip address 192.168.12.2 255.255.255.0

R4(config-if)#no shut

R4(config-if)#int f1/0

R4(config-if)#ip address 192.168.22.2 255.255.255.0

R4(config-if)#no shut

R4(config-if)#int f2/0

R4(config-if)#ip address 192.168.32.2 255.255.255.0

R4(config-if)#no shutR4(config)#router rip 創建RIP協議

R4(config-router)#version 2 版本號為2

R4(config-router)#no auto-summary 關閉自動匯總

R4(config-router)#network 192.168.12.0 地址宣告進RIP

R4(config-router)#network 192.168.22.0 地址宣告進RIP

R4(config-router)#network 192.168.32.0 地址宣告進RIP

擴展命令:

R1(config)#show ip rip da 查看rip database (從鄰居收集來的信息)的

R1(config)#no auto-summary 關閉自動匯總

R1(config)#show run | s rip 查看RIP配置

R1(config)#Show ip rout 查看路由表

R1(config-if)#ip rip send version 2 指定一個接口可以發送的RIP的版本

R1(config-if)#ip subnet-zero 允許接口的地址和路由選擇更新使用全0子網

R1(config)#interface serial 0/0

R1(config-if)#ip summary-address rip 10.0.0.0 255.0.0.0 手動開始匯總

R1(config)#key chain cisco 定義rip中加密密鑰鏈

R1(config-keychain)#key 0 定義密鑰

R1(config-keychain-key)#key-string cisco 定義密鑰值

R1(config-if)#ip rip authentication key-chain cisco 在接口上調用密鑰

R1(config-if)#ip rip authentication mode text 選擇加密方式 明文

R1(config-if)#ip rip authentication mode md5 選擇加密方式 密文

文章出自:CCIE那點事 http://www.qdxgqk.live/ 版權所有。本站文章除注明出處外,皆為作者原創文章,可自由引用,但請注明來源。 禁止全文轉載。
本文標題:思科rip技術詳解
本文鏈接:http://www.qdxgqk.live/?p=3042轉載請注明轉自CCIE那點事
如果喜歡:點此訂閱本站
上篇文章:
下篇文章:
?
?
萌宠夺宝游戏