原創:使用cisco路由器撥號,nat內網共享上網

來源:本站原創 網絡技術 超過1,756 views圍觀 0條評論

使用cisco路由器撥號,nat內網共享上網。

配置步驟:

分2大部分

第一部分:

1.創建一個acl , 可以是標準acl,也可以是擴展acl。(抓上網用戶的網段)

access-list 1 permit 192.168.0.0 0.0.255.255

或者

access-list 100 permit ip any any

2.配置nat(NAT映射)

ip nat inside source list 1 interface dialer1 overload

|

此接口,為撥號接口

不明白,可以接著往下看

3.將nat配置運用到接口(dialer撥號接口)

int dialer1 //撥號接口

ip nat outside //out出去方向

int e0/1 //局域網接口,需要做NAT出去的接口可以是多個.

ip nat inside //in進入的方向

第二部分PPPOE撥號的創建

1.開啟VPDN(建立PPOE標識)

vpdn enable

vpdn-group pppoe_client

request-dialin

protocol pppoe

exit

exit

2.進入撥號接口的物理接口

int e0/0 //與mode相連的那個接口

no ip add //沒有地址

no shut

pppoe enable //開啟pppoe功能

pppoe-client dial-pool-number 1 //這里是個關鍵點,與虛擬撥號接口關聯起來。請認真揣摩一下這句話。

注意這個pppoe-client 和上面的pppoe_client 是完全2個不同的東西,后者是命令,前者是個標識,是個名稱。

3.最關鍵的部分了,配置虛擬撥號接口。

int dialer 1 //進入虛擬撥號接口

encapsulation ppp //封裝協議ppp

ppp pap sent-username [email protected] password 13714240380 //pap 認證 賬號[email protected] 密碼13714240380,就是你的ADSL撥號賬號和密碼

本實驗指的是電信是PAP認證,如果是CHAP認證,配置要稍微復雜點,你必須得去了解CHAP認證。

dialer pool 1 //注意,虛擬接口和上面的物理接口是關聯起

ip mtu 1492 //MTU 知道吧。為什么不是1500?

ip nat outside //前面有提到

ip address negotiated //獲取ip地址。使用電腦撥號,不也需要動態獲取個IP

最后別忘了添加一條默認路由

ip route 0.0.0.0 0.0.0.0 dialer1

圖:

image

實例:

2811#sh run

Building configuration…

Current configuration : 1306 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname 2811

!

boot-start-marker

boot-end-marker

!

enable password cisco

!

no aaa new-model

clock timezone GMT 8

!

!

ip cef

!

!

multilink bundle-name authenticated

vpdn enable

!

vpdn-group pppoe_client

request-dialin

l2tp tunnel receive-window 1024

!

!

!

!

username cisco privilege 15 password 0 cisco

archive

log config

hidekeys

!

!

!

!

!

interface FastEthernet0/0

no ip address

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

pppoe enable

pppoe-client dial-pool-number 1

!

interface FastEthernet0/1

ip address 192.168.1.254 255.255.255.0

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

!

interface Dialer1

ip address negotiated

ip mtu 1492

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

ppp pap sent-username ad65039771 password 0 vGQifu7S

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 192.168.2.0 255.255.255.0 192.168.1.1

!

!

ip http server

ip nat inside source list 101 interface Dialer1 overload

!

access-list 101 permit ip any any

!

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

login local

line vty 5 15

login local

!

scheduler allocate 20000 1000

!

end

文章出自:CCIE那點事 http://www.qdxgqk.live/ 版權所有。本站文章除注明出處外,皆為作者原創文章,可自由引用,但請注明來源。 禁止全文轉載。
本文鏈接:http://www.qdxgqk.live/?p=3022轉載請注明轉自CCIE那點事
如果喜歡:點此訂閱本站
?
?
萌宠夺宝游戏