cisco2811語音網關+callmanager撥打外線,外線撥入詳解配置

來源:本站原創 Voice 超過1,619 views圍觀 0條評論

cisco2811語音網關+callmanager撥打外線,外線撥入詳解配置
——————包括AA和連接PBX的配置 這是我們公司內部的IP語音網絡環境,忙活了好幾天總算弄明白了。 基本拓撲圖如下:

 

http://img.bimg.126.net/photo/DoR6c1OuGieMtON3r7wuDg==/449234062847054745.jpg
A.首先要在callmanager上進行h.323和router pattern的簡單配置 B.下面是在CISCO2811路由器上的配置—-此路由上安裝了一個4FXO口的語音模塊 1.下面是AA的配置: application
service aa flash:its-CISCO.2.0.1.0.tcl //調用TCL腳本,定義服務名字為aa(Auto Attendant)
paramspace english language en/定義語言為英文,這個無所謂,反正你播放的是中文的welcome.au就可以了
paramspace english index 1//定義索引位置
param operator 888????????????????????????? //設置人工總機為888
paramspace english location flash:
param aa-pilot 678????????????????????? //設置自動話務員的號碼,這個隨便設
param welcome-prompt en_welcome.au????? //設置提示音,自己錄制時注意格式.au,8-bit,8kHZ,u-law 各音頻文件名與系統自帶的文件名一致,重啟路由器 2.在接口上的配置: interface Loopback0???? //為了使本地可以撥打AA自動話務員,需要配置這個地址
ip address 1.1.1.1 255.255.255.0 //此地址隨意
!
interface FastEthernet0/0
ip address 121.29.221.138 255.255.255.0
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
crypto map mymap //將保密映射應用到接口上,指定要使用的加密圖
!
interface FastEthernet0/1
ip address 192.168.100.3 255.255.255.0
ip nbar protocol-discovery
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
h323-gateway voip interface 3.voice-port的配置: voice-port 0/0/0??? //進入語音端口FXO配置模式
cptone CN????????? //配置鈴音使用中國制式
timeouts call-disconnect 1
timeouts wait-release 1???? //定義呼叫、等待時間
!
voice-port 0/0/1???????????? //此端口連接PSTN
supervisory disconnect dualtone mid-call
cptone CN
timeouts call-disconnect 1
timeouts wait-release 1
caller-id enable
!
voice-port 0/0/2???????????? //此端口連接PSTN
supervisory disconnect dualtone mid-call//配置Tone管理斷開——主要是外線撥打IP電話時,不能及時掛斷的方法
cptone CN
timeouts call-disconnect 1//呼叫中斷的超時設定
timeouts wait-release 1//等待釋放的超時設定
!
voice-port 0/0/3???????????? //此端口連接PBX的FXS口
supervisory disconnect dualtone mid-call
cptone CN
timeouts call-disconnect 1
timeouts wait-release 1 4.撥打外線的配置: dial-peer voice 2 pots //配置一個POTS撥號對等體(和配置靜態路由時的ip route命令類似)
service aa
destination-pattern 9T//表示9+電話號碼,即撥出的電話號碼,表示號碼前加入9才能通過這個端口出局
incoming called-number .
port 0/0/1?? ////指定端口(FXO口0/0/1)
!
dial-peer voice 4 pots
service aa
destination-pattern 9T
incoming called-number .
port 0/0/2
!
dial-peer voice 200 pots
service aa
destination-pattern .T //.表示一個任意數字,T表示多個任意數字
port 0/0/3 5.外線撥入和PBX上模擬電話撥打IP電話的配置: dial-peer voice 344 voip//配置一個VOIP撥號對等體
destination-pattern 6..//內部IP分機
session target ipv4:192.168.100.209//會話目標IP(和配置靜態路由時的下一跳地址類似)
dtmf-relay h245-alphanumeric//DTMF使用h245-alphanumeric,寫錯了就無法輸入分機號碼了
codec g711ulaw?? //強制使用G.711ulaw,否則容易因為codec出問題
no vad?????????? //關閉VAD,否則容易出毛病
!
dial-peer voice 345 voip
destination-pattern 5..
session target ipv4:192.168.100.209
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
dial-peer voice 300 voip?? //配置與實驗室2811CME的電話互通
destination-pattern 4..
session target ipv4:192.168.100.11 //實驗室2811的F0/1接口地址
!
dial-peer voice 10 voip
service aa
destination-pattern 678?? //使本地可以撥打自動話務員,必須配合下面的session
session target ipv4:1.1.1.1//
incoming called-number 678 //配置撥入的電話為678的時候,才調用server aa
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad

本文出自 “小魚的理想” 博客,請務必保留此出處http://yushuicheng.blog.51cto.com/406234/150808

文章出自:CCIE那點事 http://www.qdxgqk.live/ 版權所有。本站文章除注明出處外,皆為作者原創文章,可自由引用,但請注明來源。 禁止全文轉載。
本文鏈接:http://www.qdxgqk.live/?p=286轉載請注明轉自CCIE那點事
如果喜歡:點此訂閱本站
  • 相關文章
  • 為您推薦
  • 各種觀點
?
暫時還木有人評論,坐等沙發!
發表評論

您必須 [ 登錄 ] 才能發表留言!

?
?
萌宠夺宝游戏