關于PPP Multilink協議的配置

來源:本站原創 網絡技術 超過1,677 views圍觀 0條評論

使用2個E1捆綁實現4M的數據傳輸,現把文檔寫出來供大家參考。

PPP Multilink協議(MP)是PPP(點對點協議)的擴展,它具有綁定兩條或多條同步并行連接的能力。所產生的虛擬連接擁有的帶寬等于各條獨立連接的帶寬的總和。 PPP包含有用來重組和排序的信息。 MP在需要時可以把包切割成碎片(fragment)以符合MTU(最大傳輸單元)的值,或者也可選擇把整個包發送到可用的鏈路上。MP沿著首選的可用鏈路傳輸每一個單獨的包或碎片,附帶有額外的信息,以使接受端可以把這些碎片重新組合成單個包,再進行路由轉發。 MP是包含綁定的帶寬整合的一種形式,它是RFC 1990.MP所定義的非專有TCP/IP標準的一個組成部分。工作原理 PPP Multilink把單個PPP連接分割為兩條獨立的物理鏈路,然后以正確的順序重新組合它們。要實現這一點的話必須在鏈路的兩端都有一個遵從MP協議的硬件設備或軟件程序。MP是這樣來執行以上功能的: l 源端的MP收到數據包 l 把它們切割成碎片(可選) l 決定下一條可用的鏈路 l 添加一個包含順序號和其它信息的PPP Multilink包頭 l 把數據包或碎片轉發到可用的鏈路上 l 接受端的MP收到數據包或數據包碎片 l 移去MP包頭 l 重新把碎片組合成完整的包 l 轉發數據包到相應的IP地址結果是,不管這些鏈路在容量上有多大的差別,也不管可用帶寬浮動得多么厲害,也能在可用的鏈路上平滑地分配流量。主要優勢 PPP Multilink的主要優勢在于:它是公開的標準,因此至少在理論上提供了跨廠商的協同工作能力和兼容性。甚至對于單條TCP/IP連接也同樣具有優勢,例如一個FTP下載,就能夠從多鏈路中得到好處。假如你透過綁定兩條鏈路的一個PPP Multilink連接下載一個文件,下載的速度將會快兩倍。不管是FTP客戶端還是服務器端都不會知道中間是一個多鏈路的連接。簡單來說,由于PPP Multilink是透明的協議,任何在主機和客戶端之間使用單連接的協議,例如終端仿真,都將從多鏈路所提供的帶寬整合中得益。

3.2 網絡具體配置甲地cisco3640路由器:

 

dyjrtlo(config)#controller e1 3/0

dyjrtlo(config-controller)#framing no-crc4

dyjrtlo(config-controller)#linecode hdb3

dyjrtlo(config-controller)#channel-group 0 timeslots 1-31

dyjrtlo(config-controller)#exit

dyjrtlo(config)#controller e1 3/1

dyjrtlo(config-controller)#framing no-crc4

dyjrtlo(config-controller)#linecode hdb3

dyjrtlo(config-controller)#channel-group 0 timeslots 1-31

dyjrtlo(config-controller)#exit

dyjrtlo(config)#interface multilink 1

dyjrtlo(config-if)#ip address 132.100.19.70 255.255.255.252

dyjrtlo(config-if)#ppp multilink

dyjrtlo(config-if)#multilink-group 1

dyjrtlo(config-if)#no ppp multilink fragmentation

dyjrtlo(config-if)#ip access-group 101 in

dyjrtlo(config-if)#exit

dyjrtlo(config)#interface s 3/0:0

dyjrtlo(config-if)#no ip address

dyjrtlo(config-if)#no ip access-group 101 in

dyjrtlo(config-if)#encapsulation ppp

dyjrtlo(config-if)#ppp multilink

dyjrtlo(config-if)#multilink-group 1

dyjrtlo(config-if)#exit

dyjrtlo(config)#interface s 3/1:0

dyjrtlo(config-if)#no ip address

dyjrtlo(config-if)#encapsulation ppp

dyjrtlo(config-if)#ppp multilink

dyjrtlo(config-if)#multilink-group 1

dyjrtlo(config-if)#exit dyjrtlo#wr

乙地OMC機房cisco3640路由器:

dzjrt1o(config)#controller e1 0/1

dzjrt1o(config-controller)#framing no-crc4

dzjrt1o(config-controller)#linecode hdb3

dzjrt1o(config-controller)#channel-group 0 timeslots 1-31

dzjrt1o(config-controller)#exit

dzjrt1o(config)#controller e1 2/1

dzjrt1o(config-controller)#framing no-crc4

dzjrt1o(config-controller)#linecode hdb3

dzjrt1o(config-controller)#channel-group 0 timeslots 1-31

dzjrt1o(config-controller)#exit

dzjrtlo(config)#interface multilink 1

dzjrtlo(config-if)#ip address 132.100.19.69 255.255.255.252

dzjrtlo(config-if)#ppp multilink

dzjrtlo(config-if)#multilink-group 1

dzjrtlo(config-if)#no ppp multilink fragmentation

dzjrtlo(config-if)#ip access-group 101 in

dzjrtlo(config-if)#exit

dzjrtlo(config)#interface s 2/1:0

dzjrtlo(config-if)#no ip address

dzjrtlo(config-if)#no ip access-group 101 in

dzjrtlo(config-if)#encapsulation ppp

dzjrtlo(config-if)#ppp multilink

dzjrtlo(config-if)#multilink-group 1

dzjrtlo(config-if)#exit

dzjrtlo(config)#interface s 0/1:0

dzjrtlo(config-if)#no ip address

dzjrtlo(config-if)#encapsulation ppp

dzjrtlo(config-if)#ppp multilink

dzjrtlo(config-if)#multilink-group 1

dzjrtlo(config-if)#exit dzjrtlo#wr

文章出自:CCIE那點事 http://www.qdxgqk.live/ 版權所有。本站文章除注明出處外,皆為作者原創文章,可自由引用,但請注明來源。 禁止全文轉載。
本文鏈接:http://www.qdxgqk.live/?p=223轉載請注明轉自CCIE那點事
如果喜歡:點此訂閱本站
  • 相關文章
  • 為您推薦
  • 各種觀點
?
暫時還木有人評論,坐等沙發!
發表評論

您必須 [ 登錄 ] 才能發表留言!

?
?
萌宠夺宝游戏