NTP時鐘 配置指南

來源:本站原創 CISCO 超過3,595 views圍觀 0條評論

路由器日志顯示時間戳
提問 在路由器 的日志和排錯信息里面顯示時間
回答
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#service timestamps log datetime localtime
Router(config)#service timestamps debug datetime localtime
Router(config)#end
Router#
注釋 還可以在命令后面加上show-timezone, msec等參數讓時間戳包含時區信息和毫秒級
14.2.  設置時間
提問 設置路由器時間
回答
內渴敝?/span>
Router#clock set 14:27:22 January 29 2006
Router#
高端路由器使用電池保存時間
Router#calendar set 14:34:39 January 29 2006
Router#
注釋 如果沒有電池保護路由器重啟時間配置消失,show calendar一方面可以顯示目前時鐘,也可以用來驗證是否有電池保護,內部時鐘和calendar時鐘不一致時可以使用clock update-calendar或者clock read-calendar來互相同步
14.3.  設置時區
提問 設置路由器時區
回答
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#clock timezone EST 5
Router(config)#end
Router#
注釋 缺省路由器使用UTC就是以前的GMT
14.4.  夏時制調整
提問 路由器自動對時鐘進行夏時制調整
回答
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#clock summer-time EDT date 26 oct 2003 02:00 6 apr 2003 02:00
或者
Router(config)#clock summer-time AEDT recurring last sun oct 02:00 last sun mar 02:00
Router(config)#end
Router#
注釋 缺省是沒有夏時制的,啟用后可以使用show clock detail來驗證
14.5.  時鐘同步(NTP)
提問 路由器自動同步網絡時間
回答
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#clock timezone EST -5
Router(config)#clock summer-time EDT recurring
Router(config)#ntp server 172.25.1.1
Router(config)#end
Router#
對于不支持NTP的路由器,使用SNTP
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#clock timezone EST -5
Router(config)#clock summer-time EDT recurring
Router(config)#sntp server 172.25.1.1
Router(config)#end
Router#
注釋 可以使用ntp source loopback0 或者ntp server 10.1.1.1 source Serial 0/0 命令來指定NTP發送的源地址。由于NTP同步的是內部時鐘,所以需要配置ntp update-calendar 來同時同步其calendar時鐘
14.6.  配置NTP 冗余
提問 配置多個NTP服務器的方式來提供冗余
回答
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#clock timezone EST -5
Router(config)#clock summer-time EDT recurring
Router(config)#ntp server 172.25.1.1
Router(config)#ntp server 10.121.33.231
Router(config)#ntp peer 192.168.12.12
Router(config)#end
Router#
注釋 無
14.7.  設置路由器為網絡NTP服務器
提問設置路由器為網絡NTP服務器,成為網絡的主時鐘源
回答
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#clock timezone EST 5
Router(config)#clock summer-time EDT recurring
Router(config)#clock calendar-valid
Router(config)#ntp master 8
Router(config)#end
Router#
注釋 這里設置ntp master 8使其成為Stratum level 8,盡量不要配置其為1
14.8.  調整NTP同步周期
提問 調整多久路由器發送NTP數據包來驗證同步
回答
NTP不允許手動修改同步頻率,但是內置的算法可以自動調整此頻率
注釋 開始為64秒一個周期,如果網絡足夠穩定此周期會逐漸增加,最長到1024秒,如下例
Router>show ntp associations
      address         ref clock     st  when  poll reach  delay  offset    disp
*~172.25.1.1       130.207.244.240   2   440  1024  377     1.6   -3.23     5.6
+~172.25.1.3       204.152.184.72    2   829  1024  377     1.7    8.06     0.9
* master (synced), # master (unsynced), + selected, – candidate, ~ configured
Router>
14.9.  NTP 發送周期性廣播包保持更新
提問 工作于廣播模式下,不需要周期性去查詢
回答
服務器端
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#clock timezone EST -5
Router1(config)#clock summer-time EDT recurring
Router1(config)#ntp server 172.25.1.1
Router1(config)#ntp server 172.25.1.2
Router1(config)#interface FastEthernet0/0
Router1(config-if)#ntp broadcast
Router1(config-if)#end
Router1#
客戶端
Router2#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router2(config)#clock timezone EST -5
Router2(config)#clock summer-time EDT recurring
Router2(config)#ntp broadcastdelay 4
Router2(config)#interface Ethernet0
Router2(config-if)#ntp broadcast client
Router2(config-if)#end
Router2#
注釋 工作于廣播模式時間數據包是單方向的,通過broadcastdelay來控制周期,廣播模式不妨礙客戶端工作于服務器客戶端模式

NTP發送周期性組播包保持更新
提問 工作于組播模式下,不需要周期性去查詢
回答
服務器端
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#clock timezone EST -5
Router1(config)#clock summer-time EDT recurring
Router1(config)#ntp server 172.25.1.1
Router1(config)#ntp server 172.25.1.3
Router1(config)#interface FastEthernet 0/0
Router1(config-if)#ntp multicast 224.0.1.1 ttl 1
Router1(config-if)#end
Router1#
客戶端
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#clock timezone EST -5
Router1(config)#clock summer-time EDT recurring
Router1(config)#ntp server 172.25.1.1
Router1(config)#ntp server 172.25.1.3
Router1(config)#interface FastEthernet 0/0
Router1(config-if)#ntp multicast 224.0.1.1 ttl 1
Router1(config-if)#end
Router1#
注釋 組播相對于廣播的好處不用多說了,并且在這個模式的初始客戶端會先發送一些單播包來測量延遲,以使時間更準確,需要注意的是不是所有的設備都支持這種組播模式
14.11.  基于接口開啟NTP
提問 路由器配置為NTP服務器,但是某些端口禁止NTP服務
回答
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface Serial0/1
Router(config-if)#ntp disable
Router(config-if)#end
Router#
或者
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#access-list 107 deny udp any eq 123 any eq 123
Router(config)#access-list 107 permit ip any any
Router(config)#interface Serial0/1
Router(config-if)#ip access-group 107 in
Router(config-if)#end
Router#
注釋 控制列表的方式更嚴格,第一種只是阻止了相應的associations,但阻止不了NTP數據包
14.12.  NTP 認證
提問 鑒權NTP數據包保證安全
回答
服務器端
Router1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router1(config)#ntp authentication-key 2 md5 neoshi
Router1(config)#ntp authenticate
Router1(config)#ntp trusted-key 2
Router1(config)#end
Router1#
客戶端
Router2#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router2(config)#ntp authentication-key 2 md5 neoshi
Router2(config)#ntp authenticate
Router2(config)#ntp trusted-key 2
Router2(config)#ntp server 172.25.1.5 key 2
Router2(config)#end
Router2#
注釋 對于廣播或者組播模式key配置為ntp broadcast key 2 和ntp multicast key 2
14.13.  限制NTP Peers數目
提問 限制路由器可以接受的NTP Peers的數目
回答
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#ntp max-associations 30
Router(config)#end
Router#
注釋 無
14.14.  限制Peers
提問 對NTP服務進行更好粒度的控制
回答
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#access-list 88 permit host 172.25.1.1
Router(config)#access-list 88 permit host 10.1.1.1
Router(config)#access-list 99 permit 172.25.0.0 0.0.255.255
Router(config)#access-list 99 permit 10.2.0.0 0.0.255.255
Router(config)#clock timezone EST -5
Router(config)#clock summer-time EDT recurring
Router(config)#ntp server 172.25.1.1 version 3
Router(config)#ntp server 10.1.1.1 version 3
Router(config)#ntp access-group peer 88
Router(config)#ntp access-group serve-only 99
Router(config)#end
Router#
注釋 路由器只允許內部時鐘從ACL88定義的兩個服務器中獲得同步,同時只有ACL99定義的兩個網段的客戶端可以從本設備請求時間信息
14.15.  設定時鐘周期
提問 希望調整自動生成的ntp clock-period xxxxxx 數值
回答
路由器在重啟之后會自動生成一個時鐘周期來加速再同步,不建議刪除或者修改
Router#show running-config | include clock-period
ntp clock-period 17180200
Router#
注釋 無
14.16.  檢查NTP狀態
提問 查看當前NTP狀態
回答
Router>show clock detail
Router>show ntp status
Router>show ntp associations
Router>show ntp associations detail
注釋 Router>show clock detail
.15:54:33.079 EST Sun Jan 29 2006
Time source is NTP
此輸出前面有個.代表此時鐘沒有同步
14.17.  NTP排錯
提問 解決NTP出錯的問題
回答
NTP非常穩定,出問題很大可能性就是連接性的問題
Router#debug ntp packets
注釋 Router#debug ntp packet
NTP packets debugging is on
.Mar 21 02:39:18: NTP: xmit packet to 172.25.1.5:
.Mar 21 02:39:18:  leap 3, mode 3, version 3, stratum 0, ppoll 64
.Mar 21 02:39:18:  rtdel 28C7 (159.286), rtdsp 2444 (141.663), refid AC190101
.Mar 21 02:39:18:  ref C043C43F.47A9CD5C (21:30:23.279 EST Wed Mar 20 2003)
.Mar 21 02:39:18:  org 00000000.00000000 (19:00:00.000 EST Thu Dec 31 1899)
.Mar 21 02:39:18:  rec 00000000.00000000 (19:00:00.000 EST Thu Dec 31 1899)
.Mar 21 02:39:18:  xmt C043C656.4DFC7394 (21:39:18.304 EST Wed Mar 20 2003)
.Mar 21 02:39:25: NTP: rcv packet from 172.25.1.5 to 172.16.2.2 on Fa0/0.1:
.Mar 21 02:39:25:  leap 3, mode 3, version 3, stratum 0, ppoll 64
.Mar 21 02:39:25:  rtdel 286E (157.928), rtdsp 0EC6 (57.709), refid AC190101
.Mar 21 02:39:25:  ref C043C4D7.1D633CDE (21:32:55.114 EST Wed Mar 20 2003)
.Mar 21 02:39:25:  org 00000000.00000000 (19:00:00.000 EST Thu Dec 31 1899)
.Mar 21 02:39:25:  rec 00000000.00000000 (19:00:00.000 EST Thu Dec 31 1899)
.Mar 21 02:39:25:  xmt C043C65D.1D0A6CBC (21:39:25.113 EST Wed Mar 20 2003)
.Mar 21 02:39:25:  inp C043C65D.1296E3C7 (21:39:25.072 EST Wed Mar 20 2003)
上面是一個debug的輸出,從中看到了來自server的數據包顯示為stratum 0,代表服務器沒有同步,既然上游服務器沒有同步,本地服務器就更不能同步了
14.18.  NTP 日志
提問 記錄重要的NTP事件
回答
Router2#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router2(config)#ntp logging
Router2(config)#end
Router2#
注釋 此命令來自12.3(7)T,下面是一個日志記錄
Router2#show logging | include NTP
000019: Jan 29 10:57:52.633 EST: %NTP-5-PEERSYNC: NTP synced to peer 172.25.1.5
000020: Jan 29 10:57:52.637 EST: %NTP-6-PEERREACH: Peer 172.25.1.5 is reachable
000024: Jan 29 11:01:20.653 EST: %NTP-4-PEERUNREACH: Peer 172.25.1.5 is unreachable
000026: Jan 29 11:15:11.985 EST: %NTP-4-UNSYNC: NTP sync is lost
14.19.  Extended Daylight Saving Time
注釋 美國為了節省能源從2007年開始調整了夏時制的設置,此略去
NTP 服務器配置
注釋 主機配置暫略去

文章出自:CCIE那點事 http://www.qdxgqk.live/ 版權所有。本站文章除注明出處外,皆為作者原創文章,可自由引用,但請注明來源。 禁止全文轉載。
本文標題:NTP時鐘 配置指南
本文鏈接:http://www.qdxgqk.live/?p=1758轉載請注明轉自CCIE那點事
如果喜歡:點此訂閱本站
上篇文章:
下篇文章:
?
?
萌宠夺宝游戏 快乐飞艇实时开奖 彩名堂腾讯分分彩下载 浙江11选5走势图一定牛 重庆时时彩开奖号码时时 有哪些漏洞能赚钱 辽宁11选5走势 双色球已开奖号码查询 大家都赚钱赚谁的钱 烈火至尊怎样赚钱 pc蛋蛋预测99预测加拿 宁夏十一选五任选走势图 金牛棋牌app官网 林疯狂拍片赚钱 排列5历史开奖号码 彩票安徽十一选五 直播答题 赚钱吗